TLS (SSL) certificate problem

The TLS (SSL) certificate has a problem: The certificate has expired or is not yet valid. It is valid from 2018-05-20 01:01:27 to 2018-08-18 01:01:27.

Has anyone seen this or know how to fix it?

my domain is dannyguest.com and is setup using box.dannyguest.com. I recently upgraded which I think is the issue as its been working flawlessly for years.

Thanks in advance
Danny Guest

Got it in my box too.
Certificate has a problem: The certificate is expiring soon: The certificate expires in 2 days on 08/26/18.
Tried to Provision, got:

Blockquote
Log:
Saving debug log to /var/log/letsencrypt/letsencrypt.log Plugins selected: Authenticator webroot, Installer None You should register before running non-interactively, or provide --agree-tos and --email <email_address> flags.

Blockquote
return config.func(config, plugins)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 1238, in certonly
le_client = _init_le_client(config, auth, installer)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 641, in _init_le_client
acc, acme = _determine_account(config)
File “/usr/lib/python3/dist-packages/certbot/main.py”, line 517, in _determine_account
config.email = display_ops.get_email()
File “/usr/lib/python3/dist-packages/certbot/display/ops.py”, line 54, in get_email
raise errors.MissingCommandlineFlag(msg)
certbot.errors.MissingCommandlineFlag: You should register before running non-interactively, or provide --agree-tos and --email <email_address> flags.

tried to give cetbot the agree via:

Blockquote
certbot --agree-tos -m MYMAIL@DOMAIN

got:

Blockquote
Certbot doesn’t know how to automatically configure the web server on this system. However, it can still get a certificate for you. Please run “certbot certonly” to do so. You’ll need to manually configure your web server to use the resulting certificate.

Blockquote:
mailadmin@mail:/$ sudo tail /var/log/letsencrypt/letsencrypt.log
2018-08-23 17:50:58,168:DEBUG:certbot.plugins.selection:No candidate plugin
2018-08-23 17:50:58,169:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None
2018-08-23 17:55:04,379:DEBUG:certbot.main:certbot version: 0.26.1
2018-08-23 17:55:04,380:DEBUG:certbot.main:Arguments: [’–agree-tos’, ‘-m’, ‘MYMAIL@MYDOMAIN.at’]
2018-08-23 17:55:04,380:DEBUG:certbot.main:Discovered plugins: PluginsRegistry(PluginEntryPoint#manual,PluginEntryPoint#null,PluginEntryPoint#standalone,PluginEntryPoint#webroot)
2018-08-23 17:55:04,386:DEBUG:certbot.log:Root logging level set at 20
2018-08-23 17:55:04,386:INFO:certbot.log:Saving debug log to /var/log/letsencrypt/letsencrypt.log
2018-08-23 17:55:04,387:DEBUG:certbot.plugins.selection:Requested authenticator None and installer None
2018-08-23 17:55:04,387:DEBUG:certbot.plugins.selection:No candidate plugin
2018-08-23 17:55:04,387:DEBUG:certbot.plugins.selection:Selected authenticator None and installer None

well got it in other topic :slight_smile:

Had this same issue, and none of the fixes worked.

I was able to resolve it by manually editing the /root/mailinabox/management/ssl_certificates.py file and adding the following two lines on line 334:

"--agree-tos",
"--email", "you@email.com", # use your email here

So it ends up looking like so:

Save the file and re-run the script using ./ssl_certificates.py

Once the SSL certificate is successfully provisioned, you can remove the two extra lines you added.