Upgrade from 0.43 to 0.56 - nextcloud issue

hello, today i tried to upgrade my a bit outdated mail-in-a-box

but the update routine doesn´t work:

FAILED: wget -O /tmp/contacts.tgz https://github.com/nextcloud-releases/contacts/releases/download/v3.3.0/contacts-v3.3.0.tar.gz
--2022-01-24 07:48:33--  https://github.com/nextcloud-releases/contacts/releases/download/v3.3.0/contacts-v3.3.0.tar.gz
Resolving github.com (github.com)...
Connecting to github.com (github.com)||:443... connected.
HTTP request sent, awaiting response... 404 Not Found
2022-01-24 07:48:34 ERROR 404: Not Found.

now i skipped the nextcloud update routine by commenting out in setup/start.sh

is there a way to easily upgrade to the recent nextcloud version? can i run the normal nextcloud update routine from command line, i don´t want to break the depencies.

thank you, kind regards, Holger

I’ve been upgrading the same install since .40, and haven’t had any problems, but I’ve been upgrading one at a time.

I don’t actually know what is the cause of the problem you are having, but many people run into problems when upgrading Nextcloud outside of the MiaB scripts, and I’m not sure if there is a clean way back from that.

Whatever you do, I recommend creating a backup prior to going any further, and save the image (my experience based on maybe older virtual tools is to shut the server down to be sure the image will be stable).

If nobody who has a better idea of what the problem might be posts here in the forum, you might also consider heading over to the slack chennel.

My best guess is you are installing from an older version, and it looks like maybe the script is running through each newer version and installing it before installing the following version, until it gets to the current version.

We’ve now had a second person report this problem:

Please post your issue to GitHub.

I did just notice there seem to be different repositories for Nextcloud. MiaB 56 is using nextcloud-releases instead of the official Nextcloud. Previous versions of MiaB (including 55) used the Nextcloud repositories.

I think you can safely upgrade to v55, I just don’t have the commands to do that immediately handy.

Actually, here is my simple way to do this:

wget https://mailinabox.email/setup.sh
chmod 755 setup.sh
nano +23 setup.sh

Change the version to match:


Then run:

sudo ./setup.sh
1 Like

Thank you @openletter this works like a charm!

1 Like

Glad to hear it.

If possible, please post your issue to GitHub so they can be aware over there.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.