Private IPv6 setting in /etc/mailinabox.conf

I recently configured an additional IPv6 address on my Linode instance. I mostly followed these instructions aside from using netplan instead of systemd.
Anyway, I set the PUBLIC_IPV6 value in /etc/mailinabox.conf, re-ran the configuration and everything seemed fine. Then I got a bounce from Gmail noting that the PTR didn’t match. While I had the RDNS entry in Linode, outgoing messages were being sent on the SLAAC address.

I can manually change /etc/postfix/main.cf and run systemctl reload postfix, but that won’t survive a reconfigure/upgrade.

I found these previous threads with similar issues:

Specifically, the second one mentions editing /etc/mailinabox.conf to change both the public and private entries.

I tried that, but every time I reconfigure with mailinabox or curl …, the configuration file is overwritten and the private address is set to the SLAAC.

Is there something I’m doing wrong or some other configuration that is overriding the PRIVATE_IPV6 setting in /etc/mailinabox.conf?

Thanks for your help.

So it looks like setup/questions.sh respects if PUBLIC_IPV6 is set, but always sets PRIVATE_IPV6.

For now I can remember to update the postfix config manually.

Anyone have any thoughts on if there’s a better way to do this or if the should be a better way to do it?