Linode problem with private IPv6 address


Thanks again for the great product, I cannot say it enough. I like the Nextcloud integration as well, we were even able to easily phase out Dropbox-like services.

We are running on Linode, and in order to resolve the “Linode issue” they assigned us a /64 range. I enabled the range on our system and configured this as our “Public IPv6” address. I successfully reconfigured mailinabox.

However, even with this change, some remote mailservers still block us with a new error, according to them the PRIVATE IP is not allowed to send mail for that domain (SPF record error). I assumed (wrongly?) the private IP is not used for outgoing connections. How does this work?

I tried to configure the private IP address to this range as well, but was unable to. It came back with the original private IP.

Thank you,

Hi, maybe the tale of my adventures can help a bit

There is a link to Linode forum with my netplan config

(I still haven’t solved the issue with my IPv6 ip resetting after reboots that are after software updates)

I have changed the smtp bind address in the configuration:
root@box:/etc/postfix# grep ‘::’ /etc/postfix/
mynetworks = [::ffff:]/104 [::1]/128

This seams to control the address postfix uses for outgoing IPv6 SMTP traffic, I am now able to send email to these addresses.
It does not seam to affect the listen address:
root@box:~# netstat -anp|grep ‘:25’|grep LISTEN
tcp 0 0* LISTEN 1259/master
tcp6 0 0 :::25 :::* LISTEN 1259/master

This worked after reboot, and I assume this will remain working on every reboot, except when MIAB setup is reran (to, for example, upgrade it). I am not sure if certbot renewal will break this as well, but I guess I will know within 90 days.

Also I have opened a ticket with Linode, perhaps they have an idea how to resolve this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.