Please turn on SMTP authentication


#1

I have a domain with about 20 aliases. These all forward to the individuals personal mail accounts. There is one account that when I email them, I get the mail bounced back as below;


This is the mail system at host box.unitymail.co.uk.

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The mail system

<usman@ali.uk.net>: host ali.uk.net[108.179.243.151] said: 550-Please turn on
SMTP Authentication in your mail client, or login to the 550-IMAP/POP3
server before sending your message. box.unitymail.co.uk
550-[159.65.85.119]:49531 is not permitted to relay through this server
without 550 authentication. (in reply to RCPT TO command)


I don’t understand why their email server thinks I am trying to relay through their machine. Anyone have any observations on this?


Email forwarding to another domain not working
#2

Just to be sure that I am looking at this correctly …

Your box is box.unitymail.co.uk and you are trying to forward a message to usman@ali.uk.net, correct? What is the origin of the email that fails, or do ALL emails to that forward fail?

Are there any other users @ali.uk.net? Or just the one? The issue COULD be the way that their server is configured. But I’d like more info before I say for sure.


#3

FYI - You cannot have an alias for a domain you do not host on your MIAB. This is probably the cause of the error message.


#4

Thanks for the replies @alento / @murgero

If I can explain further. I have MIAB set as the MX for rbrotary.org.uk, however there are no mailboxes, only aliases as forwarders.

The domain is used to allow every member of a club to have a club email address. Everyone knows that they can mail other club members as forename.surname@rbrotary.org.uk

The other end of the forwarder is whatever the user declares to me is their real address. Some use hotmail, gmail, outlook, talktalk etc. In this case the person has their own domain. I have no knowledge of how their mail is organised and I should not need it?

Mail arriving at MIAB for usman.ali@rbrotary.org.uk should be recieved then forwarded to usman@ali.uk.net

This happens ok for all other forwarders. Probably irrelevant but there is also a club@ forwarder which forwards to all the other Aliases in that domain. The problem first happened when I mailed the group and got this one bounceback. I then mailed direct and got the same result.

I have mailed from one domain that is hosted on MIAB, a domain that is served elsewhere and also from a gmail account. It fails each time with the same message, ali.uk.net refuses to accept the forwarded message from MIAB

Edit:
I perhaps should add that spf and dkim are set as per the MIAB recommendations for this domain, using external DNS server


#5

I did a little bit of digging … Ali is using M$ Outlook for his incoming email. So the rejection is compliments of Micro$oft. :frowning:
There was a discussion of this issue about a week and a half ago. One user demonstrated a potential solution - though not a perfect solution. I have asked in that thread if his fix worked with Outlook end recipients.

ETA: Even if this solution fixes the problem it is an unsupported modification to MiaB. There IS an alternative solution IF Ali is willing to take the few minutes to set it up.

Outlook/Gmail and many other providers allow users to ‘import’ email from other email account to their inbox using POP3. You could change Ali’s account to a user account rather than a alias and then he would supply his account credentials to Outlook which would then import his mail from the account usman.ali@rbrotary.org.uk which is on your MiaB. This link is a bit technical but it partially explains the situation and offers the workaround I just mentioned: