IPV6 for Mail-in-a-Box

ive been using a OVH VPS for about 3 years to host my MIB. for the last couple of days ive been getting this when sending to google mail recipients : Our system has detected that this
message is 421-4.7.0 suspicious due to the very low reputation of the
sending IP address. 421-4.7.0 To protect our users from spam, mail sent
from your IP address has 421-4.7.0 been temporarily rate limited.
i contacted OVH support and this is what i got :
Thank you for contacting OVHcloud Technical Support regarding the UCE
Protect blacklist.

Recently, UCE Protect has placed over a thousand new ASNs on their
blacklist. Unfortunately, our ASN (AS16276) has been effected by this. To
view the list of other effected ASNs and the number of new ASNs added,
please check the following links:
http://www.uceprotect.net/en/l3charts.php
http://stats.uceprotect.net/?page=su

Our legal abuse team has reached out to UCE Protect in order to remove our
ASN from the blacklist. Ultimately, UCE Protect want all of the newly
blocked ASNs to pay for express delisting. Like all major providers,
OVHcloud does not pay for blacklist delisting as it is a service outside of
our control. Paying for delisting on blacklists only leads to an increase
in blacklisting overall and ultimately hurts the industry.

UCE Protect claims automatically delist ASNs after 1 week, which we hope
will happen but as it is outside of our control, we cannot provide any
guarantees regarding this.
If you are currently effected by this, we recommend the following:

  1. To send your mail via IPv6. UCE Protect does not blacklist email sent
    via IPv6. All of our OVHcloud services come with at least a single IPv6
    address which you can configure. All major email providers now support
    IPv6.
    so it seems like IPV6 will be the only way to get around this but in the Mail-in-a-Box install guide it says to dissable IPV6 … What can i do?
1 Like

Ever since there was another thread on blacklisting, I’ve been reading up on UCEProtect. They have very little impact, and from many websites and forum threads that I’ve read, I don’t think gmail is using UCEProtect at all. (UCE is a single-person-operated scam). D/O is on the list and I have no problem, I’ve set up a server on Linode, which is on UCEProtect L3, and I also have no problem with gmail.

If Gmail really blacklisted you, UCEProtect is unlikely the reason. Do you have other users on your mail server that could have cause the blacklist? I would recommend you to switch/recreate a VPS and change your IP and see how it goes. Serving only IPV6 is not the way to go as there are still many mail servers out there that don’t read IPv6

1 Like

host alt1.gmail-smtp-in.l.google.com[142.251.9.26]
said: 421-4.7.0 [54.38.215.156 15] Our system has detected that this
message is 421-4.7.0 suspicious due to the very low reputation of the
sending IP address. 421-4.7.0 To protect our users from spam, mail sent
from your IP address has 421-4.7.0 been temporarily rate limited. Please
visit 421 4.7.0 https://support.google.com/mail/answer/188131 for more
information. kl4si8175406ejc.341 - gsmtp (in reply to end of DATA command)

Google is using UCEProtect… that is the only Blacklist im on and ive had the same IP for 3 years

Probably, but I have been on the list for a while now, no impact.

If you are determined it’s due to UCEProtect, then you either wait it out, or change your IP. IPv6 only is not recommended as stated above.

Mailinabox, if i’m not wrong is configured to run on both. If you want only IPv6, then disable your IPv4.

Other than that there’s nothing you can do on your end.

thats not my IP bro …

Couldn’t this be the explanation? My understanding is that you won’t have any impact @abardt unless you want to send a certain amount of emails to them. Is that the case? (This message merely seems to be a warning that you will be unable to send them a lot of emails. As long as your sending stays reasonable, you should be OK)

ive checked the logs … no spamming … im the only one using my server … i only send a few emails a week

Then it seems you could just disregard the message. Check that the emails are indeed received by one or two of the recipients. I guess it is the case if there are only a few a week.

i have tested by sending to 3 different Gmail addresses and my microsoft mail address… they are being blocked … did you not read my post? this is from OVH Support

UCE Protect has placed over a thousand new ASNs on their
blacklist. Unfortunately, our ASN (AS16276) has been effected by this. To
view the list of other effected ASNs and the number of new ASNs added,
please check the following links:
http://www.uceprotect.net/en/l3charts.php
http://stats.uceprotect.net/?page=su

Now that’s funny coming from you (related to the other topic). I did. I also read what Google’s message you received is saying. Anyway, good luck to you.

did you read this part?

Our system has detected that this
message is 421-4.7.0 suspicious due to the very low reputation of the
sending IP address.

https://mxtoolbox.com/SuperTool.aspx?action=blacklist%3a54.38.215.156&run=toolpage

thats the only thing out there

Yes, as all the rest. Do you mean, did I ONLY read this part? No.

Did you read the part I quoted and the 2 words I highlighted just above?
Now, maybe the sending from the others on the IP range also counts, and that’s why your emails would get rejected.

Ideally, you would want to send only to Google using IPv6. I am unable to tell you how to do this (or how to send everything using IPv6. I don’t know. I would tell you if I could).
Bye.