How to upgrade to 30 to prepare for upgrade to Ubuntu 18.04

So I’m finally getting around to upgrading from Ubuntu 14.04 to 18.04. And I see the instructions are to make sure you’re on v.30 first. I’m on v.26b.

How do I upgrade from v.26b to v.30? Can I just run the upgrade script normally and it will recognize not to upgrade me past v.30?



BTW to jump to v0.4+ over ubuntu 18.04 LTS is not an upgrade it’s a migration. See Mail-in-a-Box version v0.40 and moving to Ubuntu 18.04


Yes, I know it’s really a migration.

@kathyfeller You should be able to upgrade as you normally would to v0.30 IF you have been doing system updates. If you have not been doing system updates either I am afraid that you are looking at the potential for major problems.

When it comes time for you to upgrade to v0.30 (now?) if you have problems with Ubuntu packages being unable to update, I posted a potential solution on Github, but the person who had the issues disappeared, so it is not known if my solution was effective or not. Please reach out here or on Slack if needed.

I was doing system updates. I have no idea why I wasn’t doing mailinabox updates. (Just being stupid, I think.)

I’m not going to attempt the Ubuntu upgrade. I’m doing a clean Ubuntu install on a new droplet.

Thanks for the offer of help.

This is really the best choice … but you do indeed need to update MiaB to v0.30 first.

Or like me, you simply do not like upgrading for the sake of upgrading. :slight_smile: If there is a major security issue, I will upgrade right away, but for minor improvements , nah,

Is miab incompatible with running the Monitoring option from DigitalOcean?

I just got this:
Installing Munin (system monitoring)…
[FATAL ERROR] Lock already exists: /var/run/munin/munin-update.lock. Dying.
at /usr/share/perl5/Munin/Master/ line 128.

That is a known issue … the solution is simple, but I do not recall what it is. A quick search here and/or Github (not sure which) will yield the solution.

Okay, I google’d and based on that, I just tried running it again. It went through the 2nd time.


@alento Thanks so much for your help.

Success? Now migrated to Ubuntu 18.04?

Well, sort of. My new mail server is up and running. And your help was instrumental in that.

But I decided this was a good time to clean out my email and possibly prune accounts. So, I’m migrating the accounts over 1 by 1. I did this a year or two ago - using a mail client as my transfer mechanism. Worked fine. (But time consuming.)

Ahh, OK … so you didn’t actually do a backup restore then?

May I ask, is your provider DO or someone else? Do you intend to do a snapshot and preserve your IP? or just go forward with a new IP address?

Yeah, I’m using DO. I made a new droplet. So I’m running the old one while I migrate.

It’s kind of a pain, but my mail server is mostly just for me. And keeping the reputation doesn’t seem to do much good. The only site that refuses email from me - Microsoft’s email systems. Well, even after I spent hours and days jumping through their hoops to get registered with their system, they still started bouncing my emails as spam again a couple of months later.

And I was only sending out a about 2-3 emails a month to about 5 people. (People I know and are on a personal email list.)

I did check the ip after i spun up the droplet to make sure the new ip was not on the ban list. And once that was okay, I proceeded with the install.

Micro$oft is the devil. I assure you that you are not alone.

I recently created a SMTP relay product that I plan to market sometime in the future that will get around this inexpensively.
Another small business user that I was helping on Slack, desperately needed a solution, so due to that I created the service that I just mentioned. They have been using it for just over a month now with no issues.

I had investigated various SMTP mail relay providers and they all were rather unreliable utilizing their free tiers as they have so many people abuse the service. So due to this, using a free SMTP relay is just as bad if not worse than using none at all. To move to a paid service with most providers the cost starts at $50/month! That is simply out of reach for the majority of MiaB users.

Oh, and just an observation – I do not believe that other VPS providers are impacted by this as I am running and maintaining 3 other MiaB installs on VPS’s from other providers without this issue. I would venture a guess that DO’s IP range, or parts of it, are being blocked by M$.

Probably. But when I ran through the hoops, what they do is use some other service (that they probably own). And that service wants you to PAY them. They have a “free” thing where you can register. But obviously, it only lasted for a short time. I suspect if I had forked over money, it would work.

Hmm, I completely missed this … do you still by chance have any idea/info about this, a link perhaps? It might be helpful to know for others.
But anyways, I am not having this problem (knock on wood) and if I ever do develop it I have my smtp relay to fall back on. :slight_smile:

Looking at my notes, I had to register with Microsoft Smart Network Data Service.
Something about
then I had to register with Junk Mail Reporting Program as a company.

If that doesn’t ring a bell, let me know. And I’ll dig up the emails that they sent me…

Yep, that all rings a bell … just the paid company part is what I am unfamiliar with. If you come across it great! but if not, no worries … I’d rather use my own thing and point people to my solution if they are going to pay anyways. :slight_smile:

I haven’'t messed with M$ in a while, so it could actually be that they have started something as a paid thing … it really wouldn’t surprise me with the level of corporate greed that there is out there these days. :frowning:

Thanks for the info! It is appreciated.