Resolved: Install 0.4.0 Munin Lock already exists & provision TLS something went wrong


#1

I rebooted the box, not sure if necessary.
I re-ran the script, but you’ll need to unlink some setup scripts so the setup can re-link them.

sudo unlink /etc/systemd/system/munin.service
sudo unlink /etc/systemd/system/mailinabox.service

The install then ran through without any errors.

Also when provisioning a LE certificate from first login https://<ip_address>/admin , it will say that “something went wrong” in the pop up modal. Simple go to https://hostname.your-domain/admin and everything will be working.


#2

Is this the error you got?

image

I think the problem might be that a cron job is running munin-update while the program is trying to update munin. I get the error every fourth or fifth time I run the setup command.

Your unlinking of the munin service would have stopped the cron job from running (it that is the problem).


#3

That error doesn’t look familiar. I think it just died with no error. Sorry I didn’t take screenshot or c+p.
But thanks for explaining that error & potential reason.


#4

Yes it was this error. I’m reconfiguring and same error, same fix.
All confirmed.
Cheers