How do I make MiaB use my new IPv6 address?

I have Mail-in-a-Box running on a Linode VPS. Got assigned an IPv6 /64 subnet so I can meet Spamhaus’s requirements to get unblocked, and followed https://www.linode.com/docs/networking/linode-network/linux-static-ip-configuration/#ubuntu-18-04 to make the system use one of the new addresses. However, Mail-in-a-Box is still using the old IPv6 address, and even shows it when running mailinabox, while ip address shows both.

There are red status checks, but they are all related to DNS for domains for which I’m using external DNS. There are no red status checks for the main domain and the box’s subdomain.

I’m not really sure whether this is a Linode problem, a Mail-in-a-Box problem, or if I just screwed up somewhere. Regardless, any help would be appreciated.

Did you remove the old IPv6 from netplan?

Did you re-run sudo mailinabox for MiaB to pick up the new IP address?

Did you remove the old IPv6 from netplan?

The netplan config which I applied only contains the new one, and there are no other netplan config files on the system.

Did you re-run sudo mailinabox for MiaB to pick up the new IP address?

Yes, but the output after the first few config screens still shows the old address in “Public IPv6 Address:”.

For future reference, the fix was to remove the old IP address manually.

1 Like

Unfortunately, this did not actually work. The address was still present since SLAAC was still enabled. Disabling it caused IPv6 to stop working entirely, as Linode requires the address which is blocked by Spamhaus to be present so that IPv6 works at all.

Is there a way to solve this on the MiaB side?

If you were not the spammer who had the originating IP blacklisted in the first place then Linode owe you a clean IP. Send them a ticket.

Linode has already assigned a “clean” /64. I just need to know how to get MiaB to use it.

Take a look inside /etc/postfix/main.cf for the smtp_bind_address and smtp_bind_address6 settings to see if they shed some light on what’s going on.

It still had the old address. Editing it followed by systemctl reload postfix seems to have fixed it. Thank you.