Errors on my system status checks page on v65

My MIAB is hosted on OVH and I keep getting various errors on my System Status Checks page, that are false alarms after I checked against and

Errors such as domains not resolving etc which seems to point towards a DNS lookup issue. Is there a way to set an alternative DNS for MIAB?

  1. I rebooted several times, no effect
  2. Then finally I ran sudo mailinabox and the errors went away.

I’m still facing the same errors on System Status Checks.

For whatever reason, running sudo mailinabox made the errors go away for about 10 mins, I think it was a fluke, the real cause still seems to be the DNS that MIAB is querying against.

It was finally solved after I changed my DNS.

It seems the only way to change DNS was to install resolvconf. Please let me know if there is an easier way to change the default DNS server that the OS uses.

I’d don’t know anything about OVH but it is not unknown for cloud providers to use their own specially tweaked versions of the OS images.

Yes, we provide Ubuntu Server 22.04” … but quietly tweaked to point at their DNS, or to use their strange network settings, etc. All fine until something like MIAB relies on the things that came with the real Ubuntu image. :thinking: :cold_face: :hot_face: :persevere: :face_with_symbols_over_mouth:

Well, I wouldn’t consider pointing to their own DNS as a “tweak”. However, it is a problem because of the poor performance of their DNS.

But after troubleshooting, my actual problem is the OS does not have a direct method to re-point my DNS.

I was being polite :wink: I can understand your frustration. I’ve come across a similar issue, different cause. (If you’re still running a more-or-less standard Ubuntu) you might be able to fix things by:

  • Update /etc/resolv.conf There are lots of options but it normally just contains the address of a useful DNS server, any server that works for you should be fine, like:


  • then restart named.service

hmm, I wanted to do it without resolv since it is an additional installation

I’ve never needed to install resolv - my (pretty much vanilla) MIAB is running named, and that seems to use resolv.conf.

Thanks, the answer I needed was resolv.conf and named.

Looking inside resolv.conf, it points to, I guess that is what made it go for the DHCP’s default DNS.

But upon running sudo mailinabox, it makes resolve.conf go back to

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.