Backup duplicity error file not found. Backup never run

I am getting a backup error with duplicity. I have rerun mailinabox and it does not fix it. It is a fresh install and backup never worked.

I get the error:

[Errno 2] No such file or directory: ‘/usr/bin/duplicity’

With any backup I try, local and backblaze B2. I can’t backup becuase of this. I tried running the script directly cd maininabox managment/ and get the same error.

How do I fix this? Reruning sudo mailinabox does not work.

Looks like yesterday’s release on the duplicity gitlab PPA is missing the binary. I started another thread just a couple of minutes behind you. I’ve opened an issue on the duplicity gitlab page.

I noticed downgrading to 0.8.21 fixes my problem. as per this bug.

I emailed the PPA maintainers about this bug.

Down grading the duplicity version fixes the error in the panel, but running directly fails.

Did you get anything back from the duplicity request - my box is now complaining of the binary missing as well?

Not sure how to proceed - any help or information would be greatly appreciated!


I have opend a bug report. Please click on the bug report and tell them it affects you too.

Try downgrading duplicity to this version: 2.1.5-ppa202312281721~ubuntu22.04.1. It’s what was installed prior to the latest.

Version 0.8.21 will not work with the recent versions of MiaB.

I’ve posted a workaround in the other thread:

This is the issue.

In another thread @asm0dey mentioned where apt kept cache of the installed packages.

Here’s how rolled back to previous version.

cd /var/cache/apt/archives
ls -1 duplicity*
sudo apt remove duplicity
sudo apt-get install $PWD/duplicity_2.1.5-ppa202312281721~ubuntu22.04.1_amd64.deb  
sudo apt-mark hold duplicity

IMHO more stable version of duplicity would be better option than Personal Package Archives, but quick look at Duplicity website suggests that the one of the “stable” methods might be more stable, than the PPA.

I think I’ll keep the duplicity package on hold for a while.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.