All calendar entries for one user (me) gone

I have just noticed that I have lost all calendar entries for my user - I am not quite sure when it happened but I it must have been in the last 2 - 3 days. I have not updated recently (last update was to 0.45 round about 25.05) but have been doing Ubuntu updates each weekend. I have 3 domains (family) using my instance so cannot just restore everything, how do I go about restoring just my calendar entries? Funnily enough my wife’s calendar is perfectly OK and my contacts are all there so I am not really sure what happened. I do have nightly backups that I transfer to my Synology :blush: so I should be able to get at the data - yay!

I have tried the “normal” things as in reconfiguring my mail client (macOS, iOS) and tried to access ownCloud via the web frontend - nothing to see there. I did have my wife’s calendar syndicated and was still seeing all her entries!

I have read this: Lost all calendars and events after update but do not know where to find the script and am not sure if that will restore every bodies calendars which would make me very unpopular.

Thank you for any help given!


        echo "WARNING: This will restore the database to the point of the installation!"
        echo "         This means that you will lose all changes made by users after that point"

So any changes made after the backup was taken will be lost.

Thank you for your help - unfortunately there seems to be a problem with the backup? When I check the backups in MailInABox I have a backup from today, no problem:

but own cloud only has backups for May:


2020-05-17 might be the date that I did the update to 0.45, it does seem as if I only have ownCloud backups when I do a mail-in-the box backup.

Very weird. I then did this:

  1. Take a snapshot of the VM
  2. Firewall: disable
  3. Restore ownCloud from 17.05
  4. Rerun mailinabox to make sure everything is OK (it did an update of OwnCloud)
  5. Export ownCloud iCal via web Frontend
  6. Restore Snapshot
  7. Reboot

I now have a really messed up calendar - my calendar was called before the snapshot restore, now it has been renamed to Personal in the web frontend, some of my entries are there, some are not…

So to recap: I took a snapshot, did a restore and then exported everything, restored to the snapshot and now my calendar is back but does not have all my entries as it should…

I really do not know what I am seeing - does anybody have an idea?

OK, further problems… I noticed an update to 0.46 today so did a quick install. After the install all my past calendar entries where gone again, the ones I entered yesterday where still there? Funnily enough only I have this problem, my wife’s calendar is perfectly ok. As I had a backup of my calendar in ICS format from 17.05.2020 I imported that and now am ‘only’ missing 1 months worth of appointments… I would be grateful for any help.

I don’t/wouldn’t worry that much if I knew what the problem is/was, currently I just know that I have the problem, not what it was or how to fix it… quite unsettling!