Webmin installation?


#1

Hello all, I have just recently spun up a new droplet with Digital Ocean, and installed Mail-in-a-box.

Pleased to say, it’s working fine.

I tried to install Webmin, so I could have a server control panel. The installation itself seemed to work OK, however, when I call the Webmin URL, it just times out.

normally you would call webmin using a port no, like https:// xxx.com:10000

HAs anyone installed webmin with mail-in-a-box and got it to work? if so, how did you do it.

Thanks in advance for any response.

Alex


#2

I have Webmin installed on every server and VPS that we use. One of my sysadmin’s is a WebMin guy. Personally, I prefer the command line.

That said, I have always installed WebMin as a part of my initial server set up.

Thinking this through a bit, MiaB uses UFW as the firewall. When I do an install of MiaB, it accepts the ports that I have already opened with UFW and keeps them open.

Honestly you would be better off to start from scratch with a clean droplet. Install Webmin, create ufw rules allowing the WebMin port. I always change the default port for WebMin and SSH as part of my security process, Then install MiaB.
That would be your safest course of action.

However, if you want to try you can always add the rules for the firewall from the command line with:
sudo ufw allow 10000/tcp
sudo ufw enable
I cannot guarantee that doing it this way will survive a reboot or upgrade of MiaB. You could rerun sudo mailinabox after making the firewall changes as in theory that would note the open ports in ufw, but again I cannot guarantee the results as I have never attempted this personally.


#3

Thank you for your insight Alento,

I dont know why I didnt think of alowing the port in ufw.

Once I opened the port, webmin was there and is workng Just fine.

I like the command line as well, but webmin has some realy useful stuff, especially the file manager.

Thanks again.

Alex


#4

Agreed … :slight_smile: Glad it worked out. Did the addition survive a reboot? or have you tested further? I think it will survive a reboot just fine, but an upgrade would likely be what breaks it - but it is simple to fix.


#5

Ive not done a reboot yet, but like yourself, Im sure it would survive that.

In any event, as you say, its simple to fix.

I’m very happy now I have webmin working.

Thanks

Alex


#6

One small caveat I discovered when constructing a static site in MIAB

MIAB issues the HSTS, header, which instructs the browser to Force https. Generally this is very Good.

However, if one is serving a static site based on the domain name, using a dedicated folder for the site, the first call to webmin will work, but subsequent calls will result in a browser warning advising it cant connect due to a configuration error.

In my case, this is not a problem, as Im only serving a very simple site and can rely on using ‘default’ folder.

to overcome the error message from chrome, I removed the dedicated site folder and put the html in the default folder,

then I went to the chrome console for hsts, at chrome://net-internals/#hsts

(note this is a local folder to your browser)

and deleted the chrome hsts record for my site. This allowed me to get the webmin consol working once again .

Alex


#7

I have not encountered that issue … correct me if my presumptions are incorrect.

I presume that the HSTS stuff is happening because Webmin is using a self-signed certificate?

If that is the case, simply configure Webmin to use the LE cert provisioned to your box. Let me know if you need further instructions.

I have not used MiaB for hosting of any sites, so if my presumption is incorrect, I don’t have any suggestions beyond what you have already found.