V0.40 Installation Stopping


#1

Hello,

I’ve taken a look for similar issues to this, but I couldn’t find anything related.

I am trying to install the most recent version of MiAB on Ubuntu 18.04.01 but when I run the installation command the setup runs until it gets to “Initializing system random number generator…” the setup stops with no warning and just brings up the command prompt.

I am not very familiar with the linux terminal so I am learning this as I go but I do not know how I can check the installation logs.

What I can tell you so far:

  • This is a clean installation
  • I have attempted to run the "Curl’ command several times already to redownload the setup files
  • I have attempted to run “mailinabox” as sudo multiple times
  • I have restarted the machine several times after every install attempt.

#2

You need 18.04, I am not 100% sure that version 18.04.01 is compatible (though I haven’t installed on 18.04.01 before)

Rebuild using 18.04 LTS and try again. run sudo apt update && sudo apt upgrade -y before doing the install just to be safe.


#3

Thanks for the head up!

I’ll report back once I’ve given that a try!


#4

So I have managed to get a 18.04 (not .1) image, installed it and attempted the install and had the same issue.

I do not know if this would make a difference but I am installing this on a VM to host locally. Would this make any difference at all?


#5

Can you output the log of the install from start to finish? And also, maybe PM me syslog?


#6

Any chance you can give me heads up on what I would need to do in order to get this. The output log is fine but no idea how to get the syslog.


#7

The log file is located at /var/log/syslog


#10

So this is the output from the terminal;

box661vgsnet@box:~$ curl -s mailinabox.email/setup.sh | sudo -E bash
Installing git . . .
Selecting previously unselected package liberror-perl.
(Reading database … 131179 files and directories currently installed.)
Preparing to unpack …/liberror-perl_0.17025-1_all.deb …
Unpacking liberror-perl (0.17025-1) …
Selecting previously unselected package git-man.
Preparing to unpack …/git-man_1%3a2.17.1-1ubuntu0.4_all.deb …
Unpacking git-man (1:2.17.1-1ubuntu0.4) …
Selecting previously unselected package git.
Preparing to unpack …/git_1%3a2.17.1-1ubuntu0.4_amd64.deb …
Unpacking git (1:2.17.1-1ubuntu0.4) …
Setting up git-man (1:2.17.1-1ubuntu0.4) …
Setting up liberror-perl (0.17025-1) …
Processing triggers for man-db (2.8.3-2) …
Setting up git (1:2.17.1-1ubuntu0.4) …

Downloading Mail-in-a-Box v0.40. . .

Installing packages needed for setup…

┌────────────────────────Mail-in-a-Box Installation──────────────────────────┐
│ Hello and thanks for deploying a Mail-in-a-Box! │
│ │
│ I’m going to ask you a few questions. │
│ │
│ To change your answers later, just run ‘sudo mailinabox’ from the command │
│ line. │
│ │
│ NOTE: You should only install this on a brand new Ubuntu installation 100% │
│ dedicated to Mail-in-a-Box. Mail-in-a-Box will, for example, remove │
│ apache2. │
│ │
├────────────────────────────────────────────────────────────────────────────┤
│ < OK > │
└────────────────────────────────────────────────────────────────────────────┘

┌────────────────────────────Your Email Address──────────────────────────────┐
│ What email address are you setting this box up to manage? │
│ │
│ The part after the @-sign must be a domain name or subdomain that you │
│ control. You can add other email addresses to this box later (including │
│ email addresses on other domain names or subdomains you control). │
│ │
│ We’ve guessed an email address. Backspace it and type in what you really │
│ want. │
│ │
│ Email Address: │
│ ┌────────────────────────────────────────────────────────────────────────┐ │
│ │me@661vgs.net │ │
│ └────────────────────────────────────────────────────────────────────────┘ │
├────────────────────────────────────────────────────────────────────────────┤
│ < OK > │
└────────────────────────────────────────────────────────────────────────────┘

┌─────────────────────────────────Hostname───────────────────────────────────┐
│ This box needs a name, called a ‘hostname’. The name will form a part of │
│ the box’s web address. │
│ │
│ We recommend that the name be a subdomain of the domain in your email │
│ address, so we’re suggesting … │
│ │
│ You can change it, but we recommend you don’t. │
│ │
│ Hostname: │
│ ┌────────────────────────────────────────────────────────────────────────┐ │
│ │System hostname here (changed as I cant have links) │ │
│ └────────────────────────────────────────────────────────────────────────┘ │
├────────────────────────────────────────────────────────────────────────────┤
│ < OK > │
└────────────────────────────────────────────────────────────────────────────┘

Primary Hostname: box.661vgs,net (Changed as I cant have links)
Public IP Address:
Private IP Address: 192.168.1.14
Private IPv6 Address:
Mail-in-a-Box Version: v0.40

Updating system packages…
Installing system packages…

Current default time zone: ‘Europe/London’
Local time is now: Wed Jan 23 21:40:46 GMT 2019.
Universal Time is now: Wed Jan 23 21:40:46 UTC 2019.

Initializing system random number generator…
Creating SSH key for backup…
box661vgsnet@box:~$


#11

Also cant send PMs as new on the forum mate!


#12

You can no longer quote a whole message.


#13

Sent you one, see if you can respond mate.


#14

Dont know if you will get this mate but hit the max messages for the day!


#15

for others who may need to know, this was caused by GNOME being installed on the server.


#16

Closure is always a good thing. Thanks for the update …


#17

I can confirm it works on 18.04.1 on a fresh box.
This is the first time I’m installing it, it is awesome.


#18

Same problem here! Stopped at “Initialing system random generator”
Fresh 18.04.1 install.
Whats going on there?
Please help


#19

Switched back to 14.04 V0.30…
Is there any solution to provide a functional setup script for 0.40?


#20

Moved to a completely new Machine, same error as in 1. posting (using original 18.04 iso).


#21

Use the ubuntu SERVER ISO, not the DESKTOP iso:

https://www.ubuntu.com/download/server


#22

I always using the server-image :sunglasses:

ubuntu-18.04-server-amd64.iso