V.0.44 Failed update

Hi everyone,

At first, when running “curl -s https://mailinabox.email/setup.sh | sudo bash” from 0.43, i got a git message error, resolved with a git init, and running the setup/start.sh directly from the folder mailinabox/.git. He also said he cant found the “mailinabox” folder, so i had to recreate it (but i didnt deleted this folder before)

MiaB seems to upgrade (especially owncloud), but after reboot…its still the v0.43 running.

Trying a second update, and i still get the same error message, but without the “git” error :

sudo curl -s https://mailinabox.email/setup.sh | sudo bash

fatal: No names found, cannot describe anything.
bash: line 71: [: v0.44: unary operator expected
bash: line 82: setup/start.sh: No such file or directory

Running on an ubuntu server 18.04LTS

1 Like

Sorry I messed up the release! I forgot to push the tag to GitHub/ Should be fixed now. Thanks for reporting!

Thx, im going to try this but i will do a VPS restore of my MiaB box before upgrading

Ok it seems to be good now

all is up to date

thx !

tried this too. I made no changes to /root and - …/backup.py and…/setup/webmail.sh were listed for local changes (I did nothing with these files). Meanwhile only …/setup/webmail.sh ist shown.

error: Your local changes to the following files would be overwritten by checkout:
Please commit your changes or stash them before you switch branches.
Update failed. Did you modify something in /root/mailinbox?

I don’t know … maybe waiting for git cache, server or …? :upside_down_face::nerd_face:

… aaaah. I (made a backup) and deleted …/setup/webmail.sh (idea from another old post here). The setup routine runs without errors and created a new one.

Thanks for this wonderful Mail-in-a-box!