Used imapsync lately with MiaB?


#1

I have an 0.30 box and an 0.40 box.

imapsync, both local and online, are having issues. Can’t authenticate a user on MiaB boxes.

Similar problems?

Dennis


#2

Error message? Anything particular happening when authentication is tried?

The ports are set correctly on the client side I presume?

ETA: Wow, I just realized that you are asking about Imapsync not connecting via IMAP. @dwomack

Glad to see that you have it all sorted now. I just used imapsync online for the first time a couple of days ago … and man, I am impressed. :slight_smile:


#3

What are you setting for a username. MAke sure imapsync is using SSL on port 993 - MIAB doesn’t use non-ssl traffic (I think)


#4

I downloaded the latest version from Git and installed it on a fully patched RaspberryPi Stretch. Installed all the perl dependencies and then imapsync.

When the imapsync script runs, it probes the source and destination sites to see if SSL ports are open. The 0.30 showed closed and the 0.40 showed open. This is not correct, they both are open. Then it failed authentication for the user.

So I thought I’ll try using the online version. I created test users on both boxes and a couple of test messages in each. Then I tried the online version. It could not authenticate the source site user.

I have no problems using either box in ios devices or in OSX,

I’ll grab some logs and post post portions here.

I don’t have lots of messages to move, I just wanted to automate the process.

Dennis


#5

I still don’t know what the issue is with imapsync.

I handled my syncing by dragging messages from one account to the other account in the mail program.

That worked.

Dennis


#6

You said you were going to drop us some logs


#7

I just checked with imapsync online.

PM me and I’ll send you the logs.

The online version uses ip6. Earlier I fixed the ip6 on both boxes that were blacklisted. Maybe the lists haven’t caught up.

Dennis


#8

Honestly, this post sounds like your Raspberry Pi may not trust the SSL certificate the server is providing. Did you self-sign, or did you use a certificate authority (such as Let’s Encrypt)?


#9

Let’s Encrypt

Just reran online and it failed.

Dennis


#10

It’s an authentication issue, not an SSL one. After logs were given to me in a PM, OP forgot to put the full email as a username in imapsync.

You mean imapsync? Lets Encrypt and imapsync are unrelated.


#11

Just ran the online version again with full email address instead of just name.

Things worked the way they are supposed to.

The imapsync online web page has an error. There are popups that indicate you can just use the name and not the full email address. All I was doing was following instructions.

The version of imapsync that is running on the web site is newer than that at git.

Thank you for your patience with me.

Dennis


#12

These are misleading. Some systems use just a username, some don’t. In this case MIAB has to use full email because MIAB hosts more than one domain.