Upgrading from v0.40 to v0.41 - "RTNETLINK answers: Network is unreachable"


#1

First, Thanks to Josh, and everyone involved here. I switched all my mail domains to mailinabox about a year ago and it’s been a great experience. Any issues I’ve had (of which there have been few) until now have been able to be solved by reviewing the forums and all the great contributions. Even the migration to v0.40 on a new Ubuntu version was relatively easy because of all your great content here… so thank you all.

I’m a little stuck now and I don’t really know how to diagnose. Hoping to get some direction. Upgrading from v0.40 to v0.41. My current install is 100% functional, no issues… just trying to stay current.

When running the upgrade, the package launches and I get the error “RTNETLINK answers: Network is unreachable”. The install then proceeds and refreshes v0.40. As a relative Linux novice, I don’t really know what to do to try and diagnose what is going on.

As a side note - the only thing I’ve changed in the standard configuration since the install of v0.40 was to enable automatic package updates. Not sure if that could have anything to do with it.

Sorry to be so useless here… if it were a Windows or MSSQL issue I could offer more insight… but as I said, I’m a little challenged in the Linux space. Anyone have any thoughts on where to start?


#2

Nevermind… I figured it out. My mistake.


#3

Will you share the solution … even if it is something totally embarrassing, it may help someone down the line! Thanks!!!


#4

Seems similar to:

https://discourse.mailinabox.email/t/cant-receive-mails/


#5

Sorry, of course. I didn’t share because I felt stupid for not trying it sooner. I’m still getting the same error when running the installer, but I had just been rerunning the local setup utility:
sudo mailinabox
When I reran the install command:
curl -s https://mailinabox.email/setup.sh | sudo -E bash
it still gave the error but the install succeeded.