Update 0.40 release announcement regarding upgrading from very old versions

In the announcement for MiaB v0.40, the “About Upgrading” section states that you must first upgrade to v0.30 if you are running a version older than that. This appears to no longer be possible because the upgrade script attempts to configure nginx for php 7.0, which is EOL and no longer supported for Ubuntu 14.04 (it does not appear in the official apt repository, and has been removed from the compatibility PPA that is commonly cited around the web). When you attempt to run the upgrade script, you get the following error:

FAILED: apt-get -y -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confnew install nginx php7.0-cli php7.0-fpm
## Reading package lists...
Building dependency tree...
Reading state information...
E: Unable to locate package php7.0-cli
E: Couldn't find any package by regex 'php7.0-cli'
E: Unable to locate package php7.0-fpm
E: Couldn't find any package by regex 'php7.0-fpm'

According to the issues that have been opened (#1591, #1596), the only real reason you need to upgrade through the intermediate version is if you are using owncloud features (contacts, calendar, etc).

I suggest updating the instructions to remove the intermediate migration step, and instead offer some alternative for those using the owncloud features.

Alternatively, it might be possible to release a hotfix to v0.30 that updates the setup/web.sh script to use a supported version of PHP (7.2+). However, I’m not familiar enough with the codebase to know if all features would be compatible with a newer version of PHP.

Looks like the documentation has been updated, thanks!