Unable to provision letsencrypt certificates

After a using mailinbox for over a year over multiple releases with no problems at all my letsencrypt certificates stopped updating. Using the mailinabox admin panel I tried the manual provision option and received the “something went wrong” error.

I hadn’t updated yet to v0.21c yet so I ran the update to see if it would solve the problem. It didn’t and the installation process ended in this error:

Traceback (most recent call last):
File “management/ssl_certificates.py”, line 807, in
File “management/ssl_certificates.py”, line 450, in provision_certificates_cmdline
status = provision_certificates(env, agree_to_tos_url=agree_to_tos_url, logger=my_logger, force_domains=force_domains, show_extended_problems=show_extended_problems)
File “management/ssl_certificates.py”, line 272, in provision_certificates
import acme.messages
File “/usr/local/lib/python3.4/dist-packages/acme/messages.py”, line 4, in
from acme import challenges
File “/usr/local/lib/python3.4/dist-packages/acme/challenges.py”, line 9, in
import OpenSSL
ImportError: No module named ‘OpenSSL’

Checking the forums I couldn’t find my specific circumstances but did find the recommendation to uninstall/reinstall of pyOpenSSL when having letsencrypt certificate problems so I did that:

sudo pip3 uninstall pyOpenSSL
sudo pip3 install pyOpenSSL

Next I re-ran the certificate provisioning from within the mailinabox admin panel and everything resolved nicely.

(And thanks for Mail-in-a-Box, its great!!)

1 Like