Unable to install--fails [solved]

Very excited about this release. Looking forward to the new version. I’m currently on Ubuntu 18.04 and MIAB v55.

I have installed Ubuntu Server 22.04 on a new machine. However, every time I try to install Mail-in-a-Box by following the instructions I get to the point where it asks for the hostname, I provide it and then after a couple of minutes the installation fails. The error says:

FAILED: add-apt-repository -y ppa:duplicity-team/duplicity-release-git, followed by a lot of references to recent calls made in the code.

So–in an effort to avoid being lazy I added this to the repository myself, did an apt update and an apt upgrade. Then I did an apt install duplicity and installed it manually.

Still–even after all this the installation fails at the same location every time with the same message.

Any ideas on what else I could try? Is there an installation log file somewhere I could peruse or upload?

Just to be thorough I blitzed everything and did a fresh install of Ubuntu Server 22.04.

On a clean install I am having the same exact error as I was before I re-installed. No idea where to go from here. I admit–I don’t know where/if there is an installation log file that might give me the answer I need to resolve…

1 Like

Would you please include the whole error text? It might be the same error several of us are facing with IONOS and other VPS providers.

Thank you for the reply!

I found the cause of my original issue. Now I am facing a new issue.

During the part of the installation where it is installing nds (replacement for bind) it rewrites the resolv.conf file during the process putting as the only entry. At that point the box can no longer resolve us.archive.ubuntu.com and the installation fails. Has anyone else encountered this issue?

I manually tried to run the command to install nds and had the same results.

Respectfully and thankfully,


It seems at this point all my issues revolve around nsd not installing properly. During the nsd installation it overwrites resolv.conf and immediately the machine loses DNS resolution so it can no longer proceed with the script. I tried making resolv.conf immutable so it could not be overwritten and now the script just breaks because it is unable to replace resolv.conf.

I was under the impression that the system got its name resolution from the netplan config and that resolv.conf was a last resort. But as soon as resolv.conf is overwritten the installation is unable to continue and the miab never installs. I have manually installed nsd thinking that would prevent it from even trying to overwrite resolv.conf but no love…

Bind is used for lookups.

There is guidance on how to overcome this somewhere on this forum … just remembering where is the problem. Ok, I found the post I was thinking of, but it is too off topic for you to use, so I won’t even point you to it,

What happens if you make (add) the following entry into your /etc/hosts file? us.archive.ubuntu.com

Thank you very much for your kindness in helping. What appears to happen is that as the installation progresses at some point the /etc/resolv.conf file gets overridden and the only content of the file is nameserver Then when the installation continues pretty much anywhere on the Internet it goes to try and execute or download anything fails due to temporary failure resolving errors. I have done exactly as you prescribed with various different sites that the installation tries to get to and I’ve made it far along. I’ve made it to the nextcloud portion of the install where it is failing now.

I think using this method I will eventually get it installed but I suspect that ultimately I need to find out why it cannot resolve names with its own dns server…

What REALLY baffles me is…what is different about my fresh install of Ubuntu 22.04 compared to all of you?

Curious who your VPS provider is? So at the point you are up to, you are past nsd’s install, correct?

Yes–past the nsd install. I am hosting this on my own hardware with my own public IP.

One thing I am aware of that might play role–our CyberSecurity team has, at the outer edge of our network, blocked by default all IPs not in North America. While this issue is clearly happening locally on my machine when nsd gets installed and resolv.conf it overwritten to point locally for name resolution–it makes me wonder if nsd is needing something outside of North America to function properly and that may be why it cannot provide name resolution for itself.

Right now I am following your suggestion. I run the install. It fails after not being able to resolve some DNS name. I add the name and IP to the host file and run the install again.

Care to experiment ??? Feel brave??? :slight_smile:

Find the /mailinabox/setup/start.sh file and open it with your favorite text editor:

Find this section:

Stick the command service nsd stop after the line source setup/dns.sh then say a prayer to your favorite higher power (if you have one).

Hmm, that may fail … if it does, then hmm, gotta think this through a bit, so let me know.

Heck yeah! I’ve already installed Ubuntu twice. It’s trivial to start over at this point.

What do you have in mind?

Stand by…praying…and doing as suggested…

Do you know where the start.sh file is placed by default? Having trouble finding it.

For the root user it is in /root/mailinabox/setup/

For a sudoer it is in /home/user/mailinabox/setup/ (replace user with the username)

Fixed … was incorrect.

OK–will go back and make that change and let you know.

No love. Same issue. I’ve done so much at this point I’m thinking of going ahead an reinstalling Ubuntu from scratch. Won’t take long. If you have other suggestions to try before I do that let me know.

I was going to say maybe letting me ssh in and tinkering … a lot of this is really trial and error.

But you mentioned the non-US IP restriction, so that would kill that idea.

I just noted that there is no /var/log/nsd.log file. Almost like it never fully installed nsd.

I’ll get a fresh Ubuntu install on this thing and take a snapshot so I can easily go back. At this point I’ve done so much tinkering it is not remotely like it was at install time.

Freshly installed Ubuntu 22.04.1 with all apt-get updates and upgrade run. Snapshot taken so I can easily get back to this state. I did have someone just stop by unexpectedly so my efforts may be cut short. I have not yet tried to install miab.

I have to go offline for the night. Unexpected family showed up. I have a fresh install and will circle back when I can. I appreciate the ideas and assistance you have provided.