Unable to install commercial SSL certificate - always "Something went wrong, sorry"

Hello everyone,

I re-ran setup, rebooted the box and checked the status page, and all is green. But when I go to System -> TLS Certificates, trying to install a commercial SSL instead of using Let’s Encrypt, I see Replace Certificate under Actions. If I click Replace Certificate I get error “Something went wrong, sorry”, and the same error pops up if I go to underneath Install certificate and choose the Country.

Please shed a light if you happen to know the solution.

P.S. I have a site with the same domain name with the mailinabox but hosted on another server, and I setup custom DNS A record for the site. If I want to add SSL for the site, should I install the SSL on another server?

Thanks for your time.


If you have the web site for domain.com hosted elsewhere (not on mailinabox) then SSL will NOT work for that domain on mailinabox.

SSL is for web only in your case since mail for domain.com would still be going through box.domain.com.

I have the same problem

I have the exact same error, it would be nice to get some insight into how a certificate can be replaced.

Anyone knows why is thrown the error?
If there is a domain which A record not points to MIAB, then throwns the error always?