Trying to understand DNS settings and a lot of problems

Hi again,

Well I mentioned in other thread some errors I get.

They are below, maybe they can help to identify the cause of the problem:

Exception on /dns/dump [GET]
                                                 Traceback (most recent call last):
                                                 File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask>/", line 252>
                                                 response = self.full_dispatch_request()
                                                 File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 182>
                                                     rv = self.handle_user_exception(e)


xception on /dns/dump [GET]
                                                  Traceback (most recent call last):
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 2528, in wsgi_app
                                                      response = self.full_dispatch_request()
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1825, in full_dispatch_request
                                                      rv = self.handle_user_exception(e)
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1823, in full_dispatch_request
                                                      rv = self.dispatch_request()
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1799, in dispatch_request
                                                      return self.ensure_sync(self.view_functions[rule.endpoint])(**view_args)
                                                    File "/home/ed/mailinabox/management/", line 75, in newview
                                                      return viewfunc(*args, **kwargs)
                                                    File "/home/ed/mailinabox/management/", line 397, in dns_get_dump
                                                      return json_response(build_recommended_dns(env))
                                                    File "/home/ed/mailinabox/management/", line 1084, in build_recommended_dns
                                                      for (domain, zonefile, records) in build_zones(env):
                                                    File "/home/ed/mailinabox/management/", line 175, in build_zones
                                                      records = build_zone(domain, domains, additional_records, env)
                                                    File "/home/ed/mailinabox/management/", line 224, in build_zone
                                                      subzone = build_zone(subdomain, domain_properties, additional_records, env, is_zone=False)
                                                    File "/home/ed/mailinabox/management/", line 215, in build_zone
                                                      for value in build_sshfp_records():
                                                    File "/home/ed/mailinabox/management/", line 468, in build_sshfp_records
                                                      keys = shell("check_output", ["ssh-keyscan", "-t", "rsa,dsa,ecdsa,ed25519", "-p", str(port), "localhost"])
                                                    File "/home/ed/mailinabox/management/", line 126, in shell
                                                      ret = getattr(subprocess, method)(cmd_args, **kwargs)
                                                    File "/usr/lib/python3.10/", line 420, in check_output
                                                      return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
                                                    File "/usr/lib/python3.10/", line 524, in run
                                                      raise CalledProcessError(retcode, process.args,
                                                  subprocess.CalledProcessError: Command '['ssh-keyscan', '-t', 'rsa,dsa,ecdsa,ed25519', '-p', '22', 'localhost']' returned non-zero exit status 1.

Thanks once again for your help.

P.S.: I also found the below lines in /var/log/syslog. Just after I tried to access the External DNS page (obtaining the 500 error):

Feb 27 10:29:00 box Exception on /dns/dump [GET]#012Traceback (most recent call last):#012  File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 2528, in wsgi_app#012    response = self.full_dispatch_requ>
Feb 27 10:29:11 box kernel: [265238.333680] [UFW BLOCK] IN=eth0 OUT= MAC=f2:3c:93:e6:f2:bb:fe:ff:ff:ff:ff:ff:08:00 SRC= DST=SERVER_IP LEN=40 TOS=0x08 PREC=0x20 TTL=240 ID=5381 PROTO=TCP SPT=59747 DPT=30213 WINDOW=1024 R>

Do you recognize this IP address?

No. Never saw it before.

Can you tell me what your “myname” and “” is? Or do you need to keep that private?

Hi again!

I think my problems were solved! :slight_smile:

I followed the suggestion by @eXTric on this thread, and now I think everything is going fine.

Well, I don’t understand why that problems happened just because I blocked SSH connections through IPv6 to SSH (this is part of a little “checklist” I have/do always when I pick a new server), but, who knows. :slight_smile:

This time I noticed that the installation process delayed a bit more. And now I was asked to enter the password for the admin user (this never happened before during the several installs I done). The installer also displayed some “DNS updated” messages.

Well, I think that now everything should really be going well, and I was also able to fix the reverse DNS (but MiAB is not “detecting” it yet).

I have some errors in the MiAB stats page (MTA-STS policy is missing: STSFetchResult.NONE, etc), but I am very happy now things start doing good. :slight_smile:

This should resolve itself within a few hours if you renew the certificate provisioning or rerun the installer.

That’s great! Thank you! :wink:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.