Error "Something went wrong, sorry." when accessing "External DNS"

Hi there,

I am trying to run external DNS as I don’t get to setup MIAB using its built-in DNS manager (as mentioned on this thread.

But, when I access the MIAB page for external DNS the error “Something went wrong, sorry.” is displayed. From now on no entries are displayed.

I tried to search in the forum for similar issues, but nothing helped me, unfortunately.

I would be extremely grateful for any help.

Looking at all the issues you had/have can you not start from scratch on a fresh image? Reinstalling and restoring my backups takes me less than 45m and is painless.
I am afraid you will spend more time debugging than starting off fresh.

1 Like

Well, I am really almost giving up.

I destroyed that server (at Linode) and created a new one.

From now on I started all over again. But, when installing MIAB, at the end of the installation in SSH a 500 Internal Error happened.

So I ran the install again, and now everything was fine.

But when trying to login in the admin area, I was told that there was no admin user, so I had to run that command to create a new admin user.

And, again, after get access to the admin area, the same errors, regarding glue records incorrect, nameservers incorrect, etc, etc.

I really don’t know what can I do more in order to have Mail in a Box running. :frowning:

If you get the “Something went wrong, sorry.” message, you might get some information that’s useful for debugging by running the following command: sudo journalctl -u mailinabox -n 25

Well, as output I got some “errors” (the only lines in red), but don’t know very well how to interpret them:

Exception on /dns/dump [GET]
                                                 Traceback (most recent call last):
                                                 File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask>/", line 252>
                                                 response = self.full_dispatch_request()
                                                 File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 182>
                                                     rv = self.handle_user_exception(e)


xception on /dns/dump [GET]
                                                  Traceback (most recent call last):
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 2528, in wsgi_app
                                                      response = self.full_dispatch_request()
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1825, in full_dispatch_request
                                                      rv = self.handle_user_exception(e)
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1823, in full_dispatch_request
                                                      rv = self.dispatch_request()
                                                    File "/usr/local/lib/mailinabox/env/lib/python3.10/site-packages/flask/", line 1799, in dispatch_request
                                                      return self.ensure_sync(self.view_functions[rule.endpoint])(**view_args)
                                                    File "/home/ed/mailinabox/management/", line 75, in newview
                                                      return viewfunc(*args, **kwargs)
                                                    File "/home/ed/mailinabox/management/", line 397, in dns_get_dump
                                                      return json_response(build_recommended_dns(env))
                                                    File "/home/ed/mailinabox/management/", line 1084, in build_recommended_dns
                                                      for (domain, zonefile, records) in build_zones(env):
                                                    File "/home/ed/mailinabox/management/", line 175, in build_zones
                                                      records = build_zone(domain, domains, additional_records, env)
                                                    File "/home/ed/mailinabox/management/", line 224, in build_zone
                                                      subzone = build_zone(subdomain, domain_properties, additional_records, env, is_zone=False)
                                                    File "/home/ed/mailinabox/management/", line 215, in build_zone
                                                      for value in build_sshfp_records():
                                                    File "/home/ed/mailinabox/management/", line 468, in build_sshfp_records
                                                      keys = shell("check_output", ["ssh-keyscan", "-t", "rsa,dsa,ecdsa,ed25519", "-p", str(port), "localhost"])
                                                    File "/home/ed/mailinabox/management/", line 126, in shell
                                                      ret = getattr(subprocess, method)(cmd_args, **kwargs)
                                                    File "/usr/lib/python3.10/", line 420, in check_output
                                                      return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
                                                    File "/usr/lib/python3.10/", line 524, in run
                                                      raise CalledProcessError(retcode, process.args,
                                                  subprocess.CalledProcessError: Command '['ssh-keyscan', '-t', 'rsa,dsa,ecdsa,ed25519', '-p', '22', 'localhost']' returned non-zero exit status 1.

It seems to me that something is going wrong while trying to create DNS zones.

It seems something goes wrong with this command:
ssh-keyscan -t rsa,dsa,ecdsa,ed25519 -p 22 localhost
What is the output if you run that command manually?

I just tried it, and had no output.

Please try it with:
ssh-keyscan -vvv -t rsa,dsa,ecdsa,ed25519 -p 22 localhost

Thank you.

So, it returned the following:

debug2: fd 3 setting O_NONBLOCK
debug3: conalloc: oname localhost kt 1
debug2: fd 4 setting O_NONBLOCK
debug3: conalloc: oname localhost kt 2
debug2: fd 5 setting O_NONBLOCK
debug3: conalloc: oname localhost kt 4
debug2: fd 6 setting O_NONBLOCK
debug3: conalloc: oname localhost kt 8

We might be chasing ghosts here, but to be sure:

  • Are you logged in using ssh?
  • Is sshd running on port 22?
  • Is there a firewall blocking port 22?

I’m not even sure ssh is the issue here, but I want to make sure there are no loose ends.

Hi there,

Yes, I am using SSH on port 22. The only “block” I made is regarding IPv6 (I am allowing only connections through IPv4).

But, really, these things are very strange. :slight_smile:

We can check if that is an issue
ssh-keyscan -4vvv -t rsa,dsa,ecdsa,ed25519 -p 22 localhost
How do you “block” ipv6?

Well, it returned a lot of lines as output.

So, I have edited /etc/ssh/sshd_config and added AddressFamily inet, so only IPv4 connections are allowed.

I am no expert but since it seems people were struggling to get miab installed without ipv6 available can you maybe try to install on a plain vanilla without any modifications.

Version 61.1 install errors - #10 by sundown

1 Like

Hi there!

@eXTric , thank you very much! :slight_smile:

You solved the problem! I’ll post more in the thread I open regarding my problems with MiAB..

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.