Still not able to update MIAB

Ubuntu Server 22.04.02
mailinabox v62 already installed
I was having issues with getting MAIB to run correctly and so made a bunch of changes in DNS, auto login, etc. So I figured I would just update to make sure all was well.
It keeps failing at this point;
FAILED: add-apt-repository -y ppa:duplicity-team/duplicity-release-git

I don’t understand why I am the only one with this issue.
This is really holding me back.

mail:/etc$ sudo add-apt-repository -y ppa:duplicity-team/duplicity-release-git
Traceback (most recent call last):
File “/usr/bin/add-apt-repository”, line 364, in
sys.exit(0 if addaptrepo.main() else 1)
File “/usr/bin/add-apt-repository”, line 347, in main
shortcut = handler(source, **shortcut_params)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 40, in shortcut_handler
return handler(shortcut, **kwargs)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 82, in init
if self.lpppa.publish_debug_symbols:
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 120, in lpppa
self._lpppa = self.lpteam.getPPAByName(name=self.ppaname)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 107, in lpteam
self._lpteam = self.lp.people(self.teamname)
File “/usr/lib/python3/dist-packages/softwareproperties/”, line 98, in lp
self._lp = login_func("%s.%s" % (self.module,,
File “/usr/lib/python3/dist-packages/launchpadlib/”, line 494, in login_anonymously
return cls(
File “/usr/lib/python3/dist-packages/launchpadlib/”, line 230, in init
super(Launchpad, self).init(
File “/usr/lib/python3/dist-packages/lazr/restfulclient/”, line 472, in init
self._wadl = self._browser.get_wadl_application(self._root_uri)
File “/usr/lib/python3/dist-packages/lazr/restfulclient/”, line 447, in get_wadl_application
response, content = self._request(url, media_type=wadl_type)
File “/usr/lib/python3/dist-packages/lazr/restfulclient/”, line 389, in _request
response, content = self._request_and_retry(
File “/usr/lib/python3/dist-packages/lazr/restfulclient/”, line 359, in _request_and_retry
response, content = self._connection.request(
File “/usr/lib/python3/dist-packages/httplib2/”, line 1693, in request
(response, new_content) = self._request(
File “/usr/lib/python3/dist-packages/launchpadlib/”, line 144, in _request
response, content = super(LaunchpadOAuthAwareHttp, self)._request(
File “/usr/lib/python3/dist-packages/lazr/restfulclient/”, line 184, in _request
return super(RestfulHttp, self)._request(
File “/usr/lib/python3/dist-packages/httplib2/”, line 1441, in _request
(response, content) = self._conn_request(conn, request_uri, method, body, headers)
File “/usr/lib/python3/dist-packages/httplib2/”, line 1363, in _conn_request
File “/usr/lib/python3/dist-packages/httplib2/”, line 1153, in connect
sock.connect((, self.port))

TimeoutError: [Errno 110] Connection timed out

Any suggestions please.

Any chance it is because I don’t have the extended update package from Ubuntu?

mail:/etc$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 22.04.2 LTS
Release: 22.04
Codename: jammy

I didn’t have the ESM package from Ubuntu when I upgraded and it worked okay, so that isn’t the problem. Did you try to just curl that server from your command line and see if it works?


Does all other connectivity work correctly? I wonder if Ubuntu was throttling or blocking your IP block because another customer of that provider was misbehaving?

I fed your entire error message to chatgpt and it thinks you’re timing out or simply have your connection interrupted. Nothing more complicated than that.

That makes even more frustrating. Since I am connecting remotely, there is obviously internet access.
The other 19 computers in my rack are working just fine.

mail:/etc$ curl Index of /duplicity-team/duplicity-release-git/ubuntu

Index of /duplicity-team/duplicity-release-git/ubuntu

Index of /duplicity-team/duplicity-release-git/ubuntu

[ICO] Name Last modified Size Description

[PARENTDIR] Parent Directory   -  
[DIR] dists/ 2023-05-09 17:13 -  
[DIR] pool/ 2020-05-07 15:30 -  

Apache/2.4.18 (Ubuntu) Server at Port 443

Seems like it is working; no?

I find it hard to believe my data center is being blocked. Though, I do like your hypothesis. Clearly this is only happening to me; so something similar to your suggestion must be happening.

How might I prove that “all other connectivity is working correctly”?

Yeah, looks like you have access to the repo. As to connectivity, nothing specific. I was reacting to your original comment that you were “having issues with getting MAIB to run correctly and so made a bunch of changes in DNS, auto login, etc”, which opens up a whole world of possibilities and questions…

I don’t have a ready answer for you, but some stuff you can try I found when trying some google-fu:
From here:

  • Install the python-is-python3 package
  • If you have ipv6 enabled, disable it, or vice versa.

If any of this helps, it would be interesting to know which VPS provider you use. Some provide deviating ubuntu images, causing such issues.

Yeah, you got me further than ever!!!
Disabling IPv6 was the winner.

Now I got to this point in the process:

Installing Nginx (web server)…
FAILED: service nginx restart

Job for nginx.service failed because the control process exited with error code.
See “systemctl status nginx.service” and “journalctl -xeu nginx.service” for details.

I downloaded the server image from Ubuntu and am putting it on my own System76 device. I didn’t have any of these issue with my other System76 device with Ubuntu 18 and the previous versions of MIAB.

So what’s the output of this command?
I imagine it can be frustrating. There have been a number of reports on the 22.04 version of MiaB where fiddling with ipv6 resolved people’s issues.

A really long output. I just rebooted. I will post the results shortly.

So you’re just now mentioning that you are installing MiaB on a desktop machine at home (basically)?

What is wrong with the System76 device? I loaded the Ubuntu Server image on it. I have two and both are for email servers of hundreds of accounts. They are both running in a data center rack.