Status check fails on newly created box

I’ve just setup a new box. Everything went fine so far. Unfortunately I get a “Something went wrong, sorry.” when accessing the status page. When I run the on the command line I get the following:


✓ All system services are running.
✓ SSH disallows password-based login.
✓ System software is up to date.
✓ Mail-in-a-Box is up to date. You are running version v0.19b.
✓ System administrator address exists as a mail alias. [ ↦]
✓ The disk has 23.6 GB space remaining.
✓ System memory is 54% free.


✓ Firewall is active.
✓ Outbound mail (SMTP port 25) is not blocked.
✓ IP address is not blacklisted by
Traceback (most recent call last):
File “/usr/lib/python3.4/multiprocessing/”, line 119, in worker
result = (True, func(*args, **kwds))
File “/usr/lib/python3.4/multiprocessing/”, line 47, in starmapstar
return list(itertools.starmap(args[0], args[1]))
File “./”, line 333, in run_domain_checks_on_domain
check_primary_hostname_dns(domain, env, output, dns_domains, dns_zonefiles)
File “./”, line 384, in check_primary_hostname_dns
ipv6 = query_dns(domain, “AAAA”) if env.get(“PUBLIC_IPV6”) else None
File “./”, line 683, in query_dns
return "; ".join(sorted(str(r).rstrip(‘.’) for r in response))
File “./”, line 683, in
return "; “.join(sorted(str(r).rstrip(‘.’) for r in response))
TypeError: str returned non-string (type bytes)

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “./”, line 940, in
run_checks(False, env, ConsoleOutput(), pool)
File “./”, line 65, in run_checks
run_domain_checks(rounded_values, env, output, pool)
File “./”, line 312, in run_domain_checks
ret = pool.starmap(run_domain_checks_on_domain, args, chunksize=1)
File “/usr/lib/python3.4/multiprocessing/”, line 268, in starmap
return self._map_async(func, iterable, starmapstar, chunksize).get()
File “/usr/lib/python3.4/multiprocessing/”, line 599, in get
raise self._value
TypeError: str returned non-string (type bytes)

I did not configure anything yet and it was indeed a really fresh Ubuntu 14.04. box. I just set up my user, enabled ipv6 and configured sshd to solely accept pubkey-authentication. Nothing else.

Does anyone have an idea?

Ok, after some investigation I found the error. The answer-object of the Python DNS-Resolver (with python 3.4.3) for an AAAA-query does convert to string correctly (__str__) returns byte instead. The same error occurs in A hot-fix can be found here: . This is no nice code (definitively too late for that today), but it does the job.

Let’s continue at thanks.

@ma0ho If you want to open a pull request with that patch, and add some code comments documenting why the changes are necessary, that would be a big help!