Status Check Error from webgui and

> eklipse@box:~/mailinabox$ sudo management/

> System
> ======
> ✓  All system services are running.
> ✖  The SSH server on this machine permits password-based login. A more secure way to log in is using a public key. Add your SSH public key to $HOME/.ssh/authorized_keys, check
>    that you can log in without a password, set the option 'PasswordAuthentication no' in /etc/ssh/sshd_config, and then restart the openssh via 'sudo service ssh restart'.
> ✓  System software is up to date.
> Traceback (most recent call last):
>   File "/usr/lib/python3.4/urllib/", line 1182, in do_open
>     h.request(req.get_method(), req.selector,, headers)
>   File "/usr/lib/python3.4/http/", line 1125, in request
>     self._send_request(method, url, body, headers)
>   File "/usr/lib/python3.4/http/", line 1163, in _send_request
>     self.endheaders(body)
>   File "/usr/lib/python3.4/http/", line 1121, in endheaders
>     self._send_output(message_body)
>   File "/usr/lib/python3.4/http/", line 951, in _send_output
>     self.send(msg)
>   File "/usr/lib/python3.4/http/", line 886, in send
>     self.connect()
>   File "/usr/lib/python3.4/http/", line 1260, in connect
>     super().connect()
>   File "/usr/lib/python3.4/http/", line 863, in connect
>     self.timeout, self.source_address)
>   File "/usr/lib/python3.4/", line 512, in create_connection
>     raise err
>   File "/usr/lib/python3.4/", line 503, in create_connection
>     sock.connect(sa)
> TimeoutError: [Errno 110] Connection timed out

> During handling of the above exception, another exception occurred:

> Traceback (most recent call last):
>   File "management/", line 967, in <module>
>     run_checks(False, env, ConsoleOutput(), pool)
>   File "management/", line 60, in run_checks
>     run_system_checks(rounded_values, env, output)
>   File "management/", line 166, in run_system_checks
>     check_miab_version(env, output)
>   File "management/", line 810, in check_miab_version
>     latest_ver = get_latest_miab_version()
>   File "management/", line 797, in get_latest_miab_version
>     return'TAG=(.*)', urllib.request.urlopen("").read()).group(1).decode("utf8")
>   File "/usr/lib/python3.4/urllib/", line 161, in urlopen
>     return, data, timeout)
>   File "/usr/lib/python3.4/urllib/", line 463, in open
>     response = self._open(req, data)
>   File "/usr/lib/python3.4/urllib/", line 481, in _open
>     '_open', req)
>   File "/usr/lib/python3.4/urllib/", line 441, in _call_chain
>     result = func(*args)
>   File "/usr/lib/python3.4/urllib/", line 1225, in https_open
>     context=self._context, check_hostname=self._check_hostname)
>   File "/usr/lib/python3.4/urllib/", line 1184, in do_open
>     raise URLError(err)
> urllib.error.URLError: <urlopen error [Errno 110] Connection timed out>

im getting this error today , i see a couple of post about this but doesn’t solved it, when i run sudo mailinabox everything looks good, im running in a ubuntu 14.04.

Getting this too and I think it’s related to the fact that is down as well.

Same thing for me. The UI status checks hang when logging into admin page.

When I do “sudo mailinabox/management/” from the MIAB machine console, the first 3 checks are ok, and then it hangs. I agree being down is related.

Also just noticed I haven’t gotten a a status check change message since 12/31 which is a relatively long time.
Could just be no 14.04 updates since then, but I’m keeping an eye out for that now.


thats solves it, it just becouse MIAB is down and we have auto-update configuration.