[Solved] Upgrade from 0.21c to 0.22 fails to upgrade Roundcube sqlite database


I recently just installed 0.21c version of mail-in-a-box on a DO droplet. However, when i upgraded to 0.22 using ‘curl -s … setup.sh | sudo bash’ and tried to access roundcube webmail, I saw the following error:


Unable to connect to the database!
Please contact your server-administrator.

Looking inside roundcubemail errors file I see the following errors repeated several times:
[02-Apr-2017 11:44:28 -0400]: DB Error: [1] no such table: carddav_addressbooks (SQL Query: SELECT id FROM carddav_addressbooks WHERE user_id=’’ AND active=1) in Roundcube/rcube_db.php on line 539 (GET /mail/)
[02-Apr-2017 11:44:28 -0400]: DB Error: [1] no such table: carddav_addressbooks (GET /mail/)

Closest issue I could find is the following:
github blind-coder/rcmcarddav/issues/96



Same here.


Close your Browser (Session), open your Browser again, then it works :wink:

That works! Awesomeness! Thanks very much!

Thanks for that.

Alternative method with Chrome is to click on the left of the address bar and delete the cookies. Then reload.

Had the same issue, but went a different way about resolving it.

Or maybe it wasn’t the same issue, as I cannot see how the cookies could impact the system not finding the databases / tables.