[Solved] - SSL Certificates - Not all my domains is visible

Hi all MiB users…

First post from me - and to all - english is not my native language - so please, smile at life :wink:

I have one little thing I can’t figured out. That is - The SSL Certificate page don’t show all my domains and therefore I can’t generate necessary CSR file.

Now - The domains in question do have both real account and aliases. I do both send and recieve from/to those.

If I login with ssh to the box and look at the /home/user-data/ssl folder - I can see them and each of them also have this ssl_certificate.pem file.

So gentlement - any hints to me? Where should I look or even better - what to do from here?

BTW - Love this awesome project - speciel love about the dns function in this whole mail/dns server packages.

Thanks in advance,

If you set custom A/AAAA records on those domains, remove those custom records.

Ok - thanks for quick reply. But if I do remove those custom A records, then the website for the domains in question will stop working, right?

I have 2 domains where the website is hosted else where therefore I have those custom A. My NS1 and NS2 is glue for all of my .dk domains

Do I only need to remove those custom A to be allowed to generate SSL and after that set those A records again?

If the website is hosted elsewhere, the SSL certificates page will have no effect — that’s why they aren’t listed.

Oooh man - sorry, my misunderstandig… So I should go to the place where the website is and then issues a CSR from there.

Thanks for your time - have a nice evening.


Okay - some info for all - on how I did manage this.

Went to my webserver, log in as a shell user, because I dont have a control panel. Then I did:

openssl req -nodes -newkey rsa:2048 -keyout domain_privkey.key -out domain.csr where domain is to be replaced with your domain.

then I answer on those:

Country Name (2 letter code) [AU]:
State or Province Name (full name) [Some-State]:
Locality Name (eg, city) []:
Organization Name (eg, company) [Internet Widgits Pty Ltd]:
Organizational Unit Name (eg, section) []:
Common Name (e.g. server FQDN or YOUR name) []:
Email Address []:

Then I open the csr filen in a editor only for copy/paste in use a Comodo SSL…

All went well and I got my certificate including some more understanding of MiB - not a bad evening. Next thing is to try to edit this threads subject with [Solved] as prefix…

Hi from DK