[Solved] Sender address rejected


#1

I have Linode VPS web.domain.uk sending daily newsletters through another Linode VPS box.domain.uk. This has worked well for over a year. On 6 Jan I updated box.domain.uk to bionic mailinabox (before 0.40 release). No issue, newsletters went out daily until 13 Jan but have not gone out 14 & 15 Jan. mail.log shows:

NOQUEUE: reject: RCPT from unknown[2a01:7e00:f03c:xxxx;xxxx:xxxx]: 553 5.7.1 news@domain.uk: Sender address rejected: not owned by user news@domain.uk; from=news@domain.uk to=sheila@otherdomain.co.uk proto=ESMTP helo=<web.domain.uk>
disconnect from unknown[2a01:7e00:f03c:xxxx;xxxx:xxxx] ehlo=2 starttls=1 auth=1 mail=1 rcpt=0/1 quit=1 commands=6/7

Here 2a01:7e00::f03c:xxxx;xxxx:xxxx is the IP of web.domain.uk
I have cross-checked that news@domain.uk is still a user on box.domain.uk

So, what changed on 13 Jan? On that date I updated with
apt-get update && apt-get upgrade
and added several other additional domains to box.domain.uk such as domain.org.uk and domain2.org.uk.
Apart from the inability of server web.domain.uk to log into box.domain.uk with the username news@domain.uk and the password of that domain everything is working fine and the mailinabox status checks are ok. I can log into news@domain.uk with Roundcube.

I am at a loss to explain this change of behaviour or fix the problem. Any clue or suggestion would be much appreciated.

[SOLVED] Lesson learned: an alias over-rides a mailbox; when making an alias be sure you don’t have a mailbox with the same name. I had completely wrongly put an alias of news@domain.uk to news@domain.org.uk. Deleting this alias solved the problem.


#2

Thank you! I been trying to solve this for hours. I didn’t realize another admin created an alias with the same email address that I created.