[SOLVED] Nextcloud Admin Unavailable


#1

Hi,

I’m really unsure what has happened. I am unable to login to the admin section of Nextcloud.

I ran the admin script a while back and I ran it again a couple of days ago, in the hope that perhaps I lost Nextcloud admin access due of the last MiaB update. Running the script again doesn’t seem to help.

Firstly, I am running the smallest DO (digital ocean) Ubuntu 14.04 box available, it is currently: Ubuntu 14.04.5 LTS (GNU/Linux 3.13.0-156-generic x86_64).

I can see the Admin option in Nextcloud as you can see:

image

So here is the message I get when I try to access the admin section:

I couldn’t see anything in /var/log/.

I installed the command line Dropbox app and then made a copy of the whole /home/user-data/ folder.

Once that backup completes, I was thinking of reinstalling MiaB, although I’m not sure what to do.

I think my current options are:

  • Somehow resolve this issue without a reinstall (maybe someone here will have some good advice on this)
  • Reinstall MiaB and then migrate my backups back in (I’m a little worried something will go wrong here)
  • Install a different mail server (mainly because I want to have more of a cloud solution* and also calendar in webmail**)

* I know MiaB comes with Nextcloud, but it seems it is best to keep MiaB untouched and then use a different server for your cloud solution - it could still be Nextcloud … just on a different server. Is it possible to link them in such a way that end users (read: my parents) won’t notice too much?

** I tried installing the offerel/caldavzap plugin into Rouncube and also the kolab ones. No luck.

I could try installing horde webmail as it does look like it integrates calendar nicely, but it does look complicated.

I might be best served by iRedmail although I’m not sure how to migrate mail and Nextcloud files across to that platform.

Does anyone have any ideas on getting Nextcloud Admin back up or migrating MiaB mail to a new system?

Thank you,
Chris


#2

For nextcloud, the logs should be in /var/logs/nginx/error.*


#3

Thank you for replying @murgero. I wasn’t sure if the nginx logs were the appropriate logs, although I guessed they might have been.

In any case, out of desperation, I did check them all out and still, unfortunately, could not find anything relating to this issue.

Now that I’ve read your message, I tried logging in again and sure enough, it failed with a new request ID. So, I checked both /var/log/nginx/error.log and /var/log/nginx/error.log.1 again, using the commands below, to no avail.

tail -n200 error.log | less
tail -n200 error.log.1 | less

Once inside each set of logs, I typed /“requestID” then enter … nothing.

Should I not be able to search the logs for the request ID? I mean, that’d make sense. Maybe grep will work better, perhaps, but am not sure that would be too different to what I’ve done.

I’m not expert so I’m sure there is a better way to troubleshoot this issue.

I hadn’t made changes to Nextcloud or MiaB in ages - i.e. not since I ran the admin script months ago and I’ve had no problems since then.

Thank you,
Chris


#4

NextCloud to me, is an unimportant ‘feature’ … however, I wonder if it is even supported at all in MiaB?

This thread:


Leads me to believe that it isn’t. I have been ‘locked out’ of it for several versions now, and really don’t care … again, that is just my preference.

What I do not know is why is NextCloud even included? Anyone?


#5

IIRC, it’s included for its ability to host calendars and contacts and to sync them. So, it’s a little bit important for MiaB. Unlocking the admin feature is definitely unsupported, that is why I am posting in the “Unsupported Modifications” forum.

I think you’ll find that:

  • Nextcloud is used for the reasons it is stated, in the link you shared, and
  • Nextcloud is unsupported for the reasons it is stated, in the link you shared.

I get it … for you it is unimportant, for me and probably others, it is! I like to make use of the functioning cloud server that comes with MiaB.

Now, I would be tempted to install another instance of Nextcloud on a new server if I knew how to link it to the MiaB one - for auth purposes. Especially if Nextcloud could run alongside multiple wordpress sites on a server.

All of this is beside the point. I’m looking to see if anyone can help here - I know it’s unsupported, but someone may have come across a similar problem and solved it themselves or has the knowledge on how to go about resolving it.

Thank you,
Chris


#6

Some times I do things backwards … so after posting my reply above I did some surfing to see what it was all about. And, I absolutely now see why it is included … normally, I see NextCloud or OwnCloud and think file storage … which is a part of it, but not the reason it would be included in MiaB.

And, honestly, I totally missed that this thread was in ‘unsupported modifications’ … from the way your OP was worded, I thought that you had lost access to something you always had access to.

So, I hope ya find the answers you are looking for … but as for me, on one of my MiaB installs I still have:

This Nextcloud instance is currently in maintenance mode, which may take a while.

This page will refresh itself when the Nextcloud instance is available again.

Contact your system administrator if this message persists or appeared unexpectedly.

Thank you for your patience.

Why this is … was never answered in another post I made months ago - again probably because the use of it is not important to me. But, I do get why you and others would want it!


#7

Cheers!

I did kind of lose access to something. I used to have access to the admin section of Nextcloud and then a week or so ago, just pfft … goooone :slight_smile:

Thanks again, I hope your issue is resolved as well!


#8

I seem to have fixed it.

I saw on a nextcloud forum that I needed to look at /home/user-data/owncloud/nextcloud.log. If you have the logreader app enabled, then you can also view it here: https://box.domain.com/cloud/index.php/apps/logreader.

I then noticed this:

OCP\AutoloadNotAllowedException: Autoload path not allowed: /usr/local/lib/owncloud/apps/onlyoffice/lib/adminsection.php

  1. /usr/local/lib/owncloud/lib/autoloader.php - line 158: OC\Autoloader->isValidPath(’/usr/local/lib/…’)
  2. [internal function] OC\Autoloader->load(‘OCA\Onlyoffice\…’)
  3. [internal function] spl_autoload_call(‘OCA\Onlyoffice\…’)
  4. /usr/local/lib/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php - line 94: ReflectionClass->__construct(‘OCA\Onlyoffice\…’)
  5. /usr/local/lib/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php - line 117: OC\AppFramework\Utility\SimpleContainer->resolve(‘OCA\Onlyoffice\…’)
  6. /usr/local/lib/owncloud/lib/private/ServerContainer.php - line 132: OC\AppFramework\Utility\SimpleContainer->query(‘OCA\Onlyoffice\…’)
  7. /usr/local/lib/owncloud/lib/private/Settings/Manager.php - line 262: OC\ServerContainer->query(‘OCA\Onlyoffice\…’)
  8. /usr/local/lib/owncloud/lib/private/Settings/Manager.php - line 290: OC\Settings\Manager->query(‘OCA\Onlyoffice\…’)
  9. /usr/local/lib/owncloud/settings/Controller/AdminSettingsController.php - line 133: OC\Settings\Manager->getAdminSections()
  10. /usr/local/lib/owncloud/settings/Controller/AdminSettingsController.php - line 72: OC\Settings\Controller\AdminSettingsController->getNavigationParameters(‘server’)
  11. [internal function] OC\Settings\Controller\AdminSettingsController->index(‘server’)
  12. /usr/local/lib/owncloud/lib/private/AppFramework/Http/Dispatcher.php - line 160: call_user_func_array(Array, Array)
  13. /usr/local/lib/owncloud/lib/private/AppFramework/Http/Dispatcher.php - line 90: OC\AppFramework\Http\Dispatcher->executeController(Object(OC\Settings\Controller\AdminSettingsController), ‘index’)
  14. /usr/local/lib/owncloud/lib/private/AppFramework/App.php - line 114: OC\AppFramework\Http\Dispatcher->dispatch(Object(OC\Settings\Controller\AdminSettingsController), ‘index’)
  15. /usr/local/lib/owncloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47: OC\AppFramework\App main(‘OC\Settings\Con…’, ‘index’, Object(OC\AppFramework\DependencyInjection\DIContainer), Array)
  16. [internal function] OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)
  17. /usr/local/lib/owncloud/lib/private/Route/Router.php - line 299: call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)
  18. /usr/local/lib/owncloud/lib/base.php - line 1004: OC\Route\Router->match(’/settings/admin’)
  19. /usr/local/lib/owncloud/index.php - line 48: OC handleRequest()
  20. {main}

I then went to https://box.domain.com/cloud/index.php/settings/apps and I disabled and removed ONLYOFFICE (wasn’t using this anyway) and External sites as I noticed other logs referring to problems with both.

Now I can login to the Nextcloud admin interface again.

I did have a Digital Ocean Spaces (Object Storage) set up with Nextcloud, but it seems that is gone now. Not sure what I am going to do re: dropbox replacement - I’m thinking I might be best to just stick with dropbox for the time being, which kind of sucks, but to have this set-up back to pretty much functional I might not worry. Or I might pay $15/month to get volume storage with DO and attach it to the MiaB setup so that the box has enough room and I don’t have to add in that extra link (DO -> External storage plugin inside Nextcloud).

Thank you,
Chris


#9

If you want big storage, look at nocix.net for their $25 plan - DEDICATED server, (better than VPS tbh) with like 2TB or something like that of space. quad core, 16GB RAM.


#10

That sounds pretty good. What are they like in terms of encryption/privacy?

To be honest, my main concern is how to seamlessly migrate all email and nextcloud data.

Do you know if you can install a hypervisor on those? If so, I could host all my servers on one of those instances.


#11

They are dedicated servers, XenServer and VMWare are available to install, or you can give them an ISO to install. Any OS is possible for them to install.

When I was using them (moved to a new provider as nocix, although AMAZING in price, is UNMANAGED meaning limited support) I used Ubuntu 16.04 with Xen installed for VM’s.


#12

Major problem there, is that 2TB disk is a single point of failure. if that goes and you don’t have a**working and tested **disaster recovery plan you are in a whole world of pain.

I am currently using Contabo (contabo.com), for MIAB and other projects the VPS a better specced than most dedicated servers and the volume is RAID 1.
However, if you are US based the latency might be an issue.
https://contabo.com/?show=vps


#13

True, but they give the option to split that across disks in raid or you can add more 2TB disks to setup raid, plus if you’re smart with off site backups then it’s not a deal breaker. At least for me anyway


#14

I don’t even mind keeping encrypted backups synced to a home raspberry pi server running Nextcloud as a federated instance. Maybe even just using resillio to sync it to a couple of computers.