[Solved]I Can't Set A Secondary Nameserver (Slave)

Sorry guys to bother you with this, but I tried the last days to add a second nameserver (slave) and I dont want to mess with the machine on the backend. But it seems like all the services I tried, dont get the access to the box to “copy” the dns settings. Does that make any sense? Does anyone experience the same or its just me?

The steps I took:

  • I registred my domain.com with the IP address of the box at the slave service and received one or more slave dns entries like ns2.afraid.org
  • I changed the DNS entries from my domain.com (I removed ns2.box.domain.com and added ns2.afraid.org
  • I checked the nameservers of my domain.com (the box is on box.domain.com) and they are ns1.box.domain.com and the domain from the slave hoster like ns2.afraid.org for example.
  • I entered the domain ns2.afraid.org in the backend of the box under Using a Secondary Nameserver and pressed Okay.

I think I am just doing something really stupid wrong. Maybe someone can help me.

Just another thing: For example Buddyns.com needs two entries, but I can only add one. I looked over at github, that feature will be implemented in the next update. Does anyone know how long this will take?


To use this, you must enter your domain, and your primary nameserver’s hostname. In order for this to work, your domain must allow AXFR transfers from ns2.afraid.org, and be delegated to ns2.afraid.org at your parent DNS servers.

AXFR transfers will originate from: to your defined master

The IP of ns2.afraid.org is and NOT Is this causing the problem?

I have no idea what I did differently today. But Buddyns.com seems to accept my settings today. Maybe I was a little bit to much in a hurry. DNS needs time, sometimes. If nothing unpleasent happens, then the guide here still seems to work at least for Buddyns.com. At puck.nether.net I could not add my domain. Thanks to @m4rcs for the guide, it finally helped.