Setting the TTL for dns record

How is this done in miab?

By default, MIAB sets the TTL to 86400, if I remember correctly. To change that you’d have to modify the either or the nsd configuration itself.

Is there something i need to do in order for the chance to take affect? Reboot? Or, run a script?


If NSD is restarted it should take effect. It won’t necessarily show up immediately in propagation though, I think. That relies on the current TTL in propagation to expire.

Is there any good reason you’re looking to change it?

In my opinion GoDaddy has an unorthodox DNS records management’s scheme, anyway when I figured it and changed them all, i had forgottent one of the records.

I should have an mx record as, instead it has

Pretty sure this is extra alias that i saw only as white space. Hence my ignorant mistake.

I thought it also might be their strange hostname requirement when i changed default name servers, although i don’t think that would be the case, since only one record was affected.

Edit: This error was apparent after the name server migration from godaddy to miab’s custom name server.


The current nameserver for

$ dig ns

; <<>> DiG 9.16.1-Ubuntu <<>> ns
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31716
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
;			IN	NS

;; ANSWER SECTION:		86400	IN	NS		86400	IN	NS

;; Query time: 76 msec
;; WHEN: Tue Apr 20 08:03:50 PDT 2021
;; MSG SIZE  rcvd: 83

Seems like everything is working?

I think it still needs to prop, I am on a time constraint with bills, so attempting to expedite the process. See below.

It is amazing how much havoc a single missed . can do to DNS.

1 Like

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.