Server Greeting Timeout on sent mail - Microsoft Servers

I have recently started to get bounce back messages when I send to Microsoft owned servers. I have seen some that are exchange/365 servers as well as one Hotmail address.

I have checked my IPs (v4 and v6) and they all show clean so not sure what the next thing to check is. I also have no errors or warnings in my system section of my admin panel as well.

Here is the error message I get from my MiaB.


Your message could not be delivered for more than 3 hour(s). It will be retried until it is 2 day(s) old. For further assistance, please send mail to postmaster. If you do so, please include this problem report.

You can delete your own text from the attached returned message. The mail system EMAIL-REDACTED: conversation with com[] timed out while receiving the initial server greeting

Does anyone know what I should look into to see what’s going on?

Debug steps I have tried:
I can telnet to that IP with port 25 from my box but only get this response:
$ telnet 25
Connected to
Escape character is ‘^]’.

C:\Users\chris> telnet 25

220 Microsoft ESMTP MAIL Service ready at Thu, 11 Apr 2024 22:07:10 +0000

500 5.3.3 Unrecognized command ‘unknown’ [ 2024-04-11T22:07:12.894Z 08DC53D0E0189EA5]

500 5.3.3 Unrecognized command ‘unknown’ [ 2024-04-11T22:07:13.441Z 08DC53D0E0189EA5]

I get something different when telneting to that IP.

Typically I would say your IP/hostname is blocked by Microsoft’s internal spam list/ policies which might be different then the “normal” lists out there.

You could try and see what you get…

Thanks @stylnchris for the quick reply.

I went through that process and they said that my IP was not blocked but it was being put through the delisting process anyway.

Any other suggestions to help me figure out what the issue may be? I am new to the self hosted game so assume I only know the basics.

Can you share any of your server details?

Is it only microsoft? can you send to others?

Microsoft (mostly 365 and one hotmail) are the only ones having the issue. other mail is sending without issue.

I can share some details. What would you need?

I guess it doesnt matter if you’ve checked all the blacklists. it does seem like microsoft is rejecting you, especially if you can send to other email servers.

perhaps try this link as well: Sign in to your Microsoft account

from this article:

Thanks for that post. That first link just makes me log in to my account with MSFT.

Any way I can check why I cannot telnet? I can’t from my box or from my local computer (in California while my MiaB server is in VA) which I think is odd…

Is port 25 allowed out of your server?

can you check another mail server?

check mine → telnet myserver 25

Got this…

Connected to
Escape character is ‘^]’.

It would seem that port 25 is blocked outbound.

What does your status page say? https://YOURSERVER.TLD/admin#system_status

Should say:

Outbound mail (SMTP port 25) is not blocked.

From my server it looks fine. I can still send email fine to other recipients.

This would be really annoying if MSFT has a server issue just after I setup a new mailserver!

send me a test email?


Thanks again for all of this help!

Didn’t get it yet, might be greylisted, Ill check back in a few more minutes.

Its been about 12 minutes – I didnt see the message even hit the mail.log

what is in your mail log?

cat /var/log/mail.log

What VPS provider do you use?

I was already checking that and just got this!

Apr 11 16:47:29 box postfix/smtp[303274]: 11BAA220085: to=<chris@neitws. com>, relay=mail.neitws. com[]:25, delay=1177, delays=877/0.08/300/0, dsn=4.4.2, status=deferred (conversation with mail.neitws. com[] timed out while receiving the initial server greeting)

I have this sitting on Contabo. I initiated a ticket with them and hopefully will hear something.

P.S. added spaces to remove the link from your emails, btw…

quick google search turns this up… I’m not very familiar with Contabo. I know others use it on this forum.

Could you kindly edit the other posts to “unlink” my email as well? I dont really care to much that its posted here but I do worry ill get more spam.

Seems contabo is “filtering it” after it leaves your server perhaps?

Yeah I saw that and that seemed to be an older post. Let me try sending to another email (my own) and see what I see.

Post edited for you.

Here’s another one, it might be your IPv4 that’s blocked but IPv6 is open which might explain why some emails are getting out and others are not.

My server is IPv4 only.

Odd, I just tried sending from my MiaB email to my gmail and it came through without delay. I have a ticket in with Contabo and will see what they say.

@stylnchris I added that setting at some point, but remeber that it was due to be overwritten on update. I forgot where that setting was. Can you point me to that location/file?

Another thing is that it seems to be intermittent. I just sent myself an email to my gmail and it worked but I sent another from the same server and it is delayed due to that failure to another gmail account.