"Sender address rejected: Not owned by user" on phpList on external server

Hello. So here is the deal:
-I have a multiple domain mail-in-a-box setup on a droplet, which is working amazingly well thanks for that.
-On another, classical dedicated server, I am hosting websites and a phpList for batch mailing.

Problem: no matter which info I use for SMTP user and sender address, the phpList test email always fails with this error message:

“Sender address rejected: not owned by user (sender’s email)”

It is not some problem with aliases, the error is same for all users, I tried multiple variants for SMTP user and sender address, even tried setting both to mail-in-a-box root email (the first mailbox created) but still getting same message.

This has been bugging me for days and I really need to start sending some emails out soon, any ideas please?

Thanks in advance.

You could try this alternative: Using MIAB as SMTP relay with ssmtp


For completeness.

Thanks, I did found that page but still having problems.

I’ve setup (almost) everything on dedicated server (the one with phpList installed) as per instructions. Same error. The only thing I didn’t do was install postfix with “Satellite system” option as postfix was already installed (though it wasn’t setup and service wasn’t active until I enabled it). Is this satellite option mandatory, do I have to reinstall postfix to fix this?
-postfix/main.cf has path to proper cert file
-credentials in relay_password are accurate
-aliases on mail-in-a-box droplet are setup

Still this error in phpList: “Sender address rejected: not owned by user (sender’s email)”

Very annoying but still I’m stubborn about using mail-in-a-box as SMTP relay, as the package info claims it is possible to use it that way. Anyone has any ideas how to diagnose this problem further?

Current status is after setting up main.cf, relay_password file and restarting postfix, test mail sent from dedicated server (phpList host) via command line still sends emails as dedicated server rather than use MIAB as relay.

Dedicated server is CentOS 6.5 I did “yum reinstall postfix” and I didn’t get any configuration screen to configure it as satellite. Is that perhaps typical for version of postfix on this version of centos? Or is there a better way to reinstall postfix which would invoke that configuration screen? There is really next to no information about this on google, otherwise I wouldn’t be asking here.

adding these lines to proposed postfix configuration:
relayhost = (box address):587
smtp_use_tls = yes

makes sending emails via command line stop working, and phpList gives same error as always.