S3 backups errors

Just upgraded to latest ubuntu and MIAB. Having problems getting S3 backup working using MinIO hosted on Docker on Synology NAS. Never used it before so who knows it could be a me issue. It is fully reachable from the web and I have the user settings set to s3:* for testing. When pointing at the bucket directly on port 9000 I get the following error that is not very helpful. I have the region set to “Other (non AWS)”. If I connect from my browser to port 9000 Minio definitely seems like everything is working. I have even tried setting the bucket to public.

<html> <head><title>504 Gateway Time-out</title></head> <body> <center><h1>504 Gateway Time-out</h1></center> <hr><center>nginx</center> </body> </html> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page --> <!-- a padding to disable MSIE and Chrome friendly error page -->

The weird thing is after getting this error I get the same error again if I try to switch back to local backups. Very confusing! Maybe a generic issue in the new MIAB?

I am bumping this post.

This is the same error with new Digitalocean Spaces.


I am bumping this post.

I am bumping this post.

Getting the same error here when setting up s3 compatible backups.

1 Like

BUMP still an issue is there any way for someone to look into this?

Please stop bumping.

What should I do to help issues get resolved? It seems like this affects any S3 compatible storage with new MIAB… I have not been able to take backups in a month and it is pretty critical.

I would suggest to use the rsync backup to your Synology to get regular backups so you lower the criticality of the issue. This type of backup works fine for my Synology.
In the mean time you can continue to investigate.

How did you get this working with synology? MIAB Rsync needs SSH key. Synology doesn’t even have home directory by default. I tried turning it on and no home directories actually get created… sigh nothing ever just works…

My setup is as follows

  • Enable rsync and use a non standard port: 2345 or something similar. My firewall only forwards the rsync port requests to Synology if it is coming from the MIAB IP for extra security.
  • Create a directory for the backup and give your admin user access
  • Temporarily turn on ssh on the Synology
  • login with your user that has admin privileges
  • sudo vi ~/.ssh/authorized_keys
  • paste the public key that is in the admin of miab
  • exit and save
  • sudo vi /etc/ssh/sshd_config and turn on “PubkeyAuthentication yes”
  • restart the ssh service (be sure that you did not make any mistakes!)
  • exit and save
  • turn off ssh
  • connect from miab don’t forget to add the port if you changed it.

if this does not work try to use the guides on internet and the command line rsync to try to manually connect step by step before using the miab

It took me some additional fiddling to get Rsync working as it seems the home directory has some known issues on Synology. Thanks for the idea to set that up.

Had to follow this guide: Fixing a Common User Home Service Error in Synology NASes | gvisoc

Then I had to manually make the home directories and assign the correct permissions, make a new user for rsync backups, grant this user all the right permissions for these folders, ensure the RSYNC service was running, manually edit sshd config, and create a new folder for the backups. This has gotten to the point I at least have backups working.

I see this ticket: S3 Compatible Backup to non AWS host connects to wrong host · Issue #2167 · mail-in-a-box/mailinabox · GitHub But in the network tab on mine it seems to be sending the correct host. Also there is nothing in the logs about connecting to AWS nor my custom synology. Not sure how to troubleshoot further. I made a new ticket S3 Compatible Backup to non AWS host not working · Issue #2230 · mail-in-a-box/mailinabox · GitHub

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.