Rsync broken in v0.15?

I’ve been rsync’ing files to my box to be displayed by the static web server. This was working swimmingly, but when I tried to update the files today, I got a message like this:

debug1: Exit status 12
rsync: connection unexpectedly closed (8540 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at /BuildRoot/Library/Caches/ [sender=2.6.9]

I’ve tried this on Windows (cygwin) as well and received a similar error message. Did anything change wrt. rsync in v0.15?


Sounds like a firewall issue. I don’t think there were any changes to Mail-in-a-Box that would affect that.

I am able to ssh into the box without a problem. If this were a firewall issue, shouldn’t both fail?

It turns out that the owning group of the www files was changed from my user to ‘user-data’. I believe that this caused SELinux to disallow the transaction. I got a better failure message after disabling compression (dropping the -z flag). In the end the solution was to ssh into the box and chown -R … www data.