Restore duplicity files

I want to restore a backup to a test location, so I can explore certain mailfolders.
I have run:
export PASSPHRASE=$(cat secret_key.txt)
duplicity restore encrypted file:///restore/

and get in the /restore directory this:


What do I do next?


Have you looked at the maintenance guide? See the moving to a new box section for restore command for local backups. Maybe that helps?

Well yes, the commands I ran came from there


export PASSPHRASE=$(cat your_backup_secret_key_file.txt)

sudo -E duplicity restore --force file:///path/to/copied/files /home/user-data/

The files you want should be unpacked to /home/user-data/ or wherever you chose should they not?

this is what I put in my original post…

I didn’t use sudo because I am root. I didn’t use -E because I’m not worried about permissions and I didn’t use --force as my raget directory os empty and anyway duplicity says it will complain if it needs force.

Well if you choose not to follow the instructions as laid out then do not expect them to function as laid out.

Like for example – where are you writing the files to? I see that you chose not to give that location in the command, so how do you expect to see files that do not exist, since they are not ever written as you do not tell where they are to be written to?

OK, I ran the command from /home/user-data/backup, so the source is the file structure encrypted/… . The destination I have specified is /restore/…

I didn’t want to risk overwriting my live system, hence the command I ran is not exactly as per the instruction


So your command was:

export PASSPHRASE=$(cat your_backup_secret_key_file.txt)

sudo -E duplicity restore --force file:///home/user-data/backup/encrypted /restore/

or in your case I presume:

`duplicity restore file:///home/user-data/backup/encrypted /restore/

Then may I ask why you are doing it on your MiaB droplet? Actually, I am not certain what your goal is here, but why not simply copy the maildirs to a ‘safe’ location and go through them there? I suspect that you are trying to verify the integrity of the backup. If so, why not simply spin up another temporary instance of MiaB and restore to it?

Ah OK then. You see only the tar files then?

also dont forget the important one

sudo mv /home/user-data /tmp/user-data.empty

I tried several testing to backup and restore, and command above save me
check this