Remote Neomutt client fails send with "sasl authentication failed"


#1

Hi,

I just installed Mail-in-a-box in a Debian 9 vps, and it’s working perfectly.

i wanted to access it through my Neomutt client on my home computer, so I wrote the following muttrc:

set from = “'user’@‘my_domain’”

set realname = “‘my_name’”

set imap_user = “'user’@‘my_domain’”

set imap_pass = “‘my_password’”

set edit_headers = yes

set smtp_url ="'user’@‘my_domain’:587/"

set smtp_pass = “‘my_password’”

set ssl_starttls = yes

set spoolfile=“imaps://’_my_domain’:’_my_password’’@‘my_hostname’/”

set folder=“imaps://‘my_hostname’/”

set tmpdir = “/tmp”

set record = “Sent”

set mbox = “+mbox”

set postponed = “Drafts”

set ssl_starttls=yes

set ssl_force_tls=yes

unset imap_passive

set imap_check_subscribed

set mail_check=60

set timeout=10

set header_cache=~/.hcache

set wait_key = no

set mbox_type = Maildir

set timeout = 3

set delete

unset confirmappend

set quit

set editor=‘tilde’

When I reentered neomutt I had access to my mail-in-a-box account.

When I tried to send a mail through it, it got to

Authenticating PLAIN

and then served the

SASL authentication failed message.

I’m very new to configuring a mail server, so I’m unsure on how to progress.

I imagine that dovecot (or Postfix, for all that I know), don’t recognize the mail client and stop the process, but I have no idea on how to proceed and I didn’t find anything on google that someone as ignorant as me could use.

Any help would be greatly appreciated.

Thanks

EDIT - Link to the log entries of when I tried to send the email: https://pastebin.com/8dK1w95x


#2

You just registered for this forum so you are limited … try combining the info to one message on pastebin or something similar…


#3

Thank you alento. I took your advice.