RainLoop in Nextcloud (MIAB v0.26+ ONLY)

After much discussion across the discourse board here, I have seen quite a few of you want to be able to use webmail in NextCloud, and some specifically wanting RainLoop. Here is a step by step for those interested.

NOTE: This is an unsupported modification, so not a lot of people will help you if you run into problems, but I have been using this setup for over a year now with no issues. Just continue at your own risk!
NOTE2: This guide assumes you have MiaB setup already and working!


  1. Login to the server via SSH, and run: bash /home/YOURUSERNAME/mailinabox/tools/owncloud-unlockadmin.sh admin@box.example.com (Change that email to the admin email you setup during install)

  2. Login to NextCloud (https://box.example.com/cloud) as your admin account.

  3. Click on your icon on the top right, you will see 2 new options +Apps & Admin, click +Apps.

  4. After it loads (Can take up to a minute, it is downloading an app list from NextCloud) go to the Social & Communications tab.

  5. Click on Enable under the RainLoop app.

  6. After enabling in NextCloud, go to NextCloud Admin panel (Click your icon in the top right, then select Admin), “Additionnal settings” and you will see a “Rainloop webmail” section. There, click on the link to go to the Rainloop admin panel. The default user/password is admin/12345. Also make sur ein the NextCloud admin that Automatically login with Nextcloud user credentials is CHECKED and hit save!

  7. in the RainLoop admin panel and then select the Domains tab. And input(the wild card is not needed if you only use 1 domain!):

  8. A new icon will appear in the NextCloud navbar, this is the RainLoop web mail, if all is configured, you should be logged in automatically and see your email!

Why would you want this? It allows you to use 1 interface for email, contacts, calendar, & files! RainLoops support CalDAV & CardDAV but that is outside the scope of this tutorial (for now).

Security Notices

  • Change the RainLoop admin password after login!
  • Do not install RainLoop plugins if you don’t need them!
  • Keep RainLoop up to date when NextCloud notifies you of an app update for it!

1 question. I have been using MIAB on a 512mb droplet with ZERO issue…
So, does RainLoop takes more memory? can I disable contacts, calendar?

Rainloop will run fine since most of it’s processing is done client side.

I might give this a try on the weekend @murgero

Thank you for taking the time to do this walk through. Have you had to re-due the changes after an upgrade, or do the changes stick?

I’ve had RainLoop setup since v0.26 and upgraded to v0.26c yesterday. Still works as expected :slight_smile:

I suspect as long as MIAB doesnt remove NextCloud, the app and settings should stay intact. 0.26c had the Nextcloud update too so even the NC update kept the app.

Nice, I’ll give it a try. I find the built-in web-mail client a little lacking. I’ll take a snapshot of my VM before running the v0.26c update, and then make this mod. v0.26b broke the DNS on my VM and caused fail-2-ban to use 100% CPU on 2 of my 4 cores. Only noticed it when clients started saying that they could not connect.

Luckily I had a good back up, but it was still a long sleepless night to get back up for my clients. Serves me right for upgrading without taking a snapshot.

0.26c has been good to me so far so I hope!

Thank you!!! I was looking for away so my employees would have only one spot for everything. I tried the mail app but missing a lot of features. Unless, the app is an official Nextcloud app I don’t consider it. So glad you recommended it.

David Swanson

RainLoop is not an official app, but a third party app. Glad you are enjoying it.

@cwilkins Did you find this helpful? RainLoop working well for you?


When I tried admin/12345, it says “authentication failed”. Any ideas what caused this?


The only thing that comes to mind is you are in the wrong admin panel…




Can you elaborate on the wrong admin panel? thanks.

You haven’t changed the password? that seems to be the correct admin panel. Confirm num/caps lock is off and try again.

People seemed trying that before with limited success. It seems that yours is a easy one. However, it doesn’t work for me. …

You installed the app in NextCloud correct? Uninstall the app from the NextCloud “+Admin” link and reinstall.

diabled app, removed, enabled…same failure…

Can you give me the output of /var/log/nginx/error.log?

Please PM it to me as it migh have IP addresses, domain names, or other sensitive data

2018/02/21 05:53:48 [error] 2154#0: *188 “/home/user-data/www/xxxxxx.com/index.php/apps/rainloop/app/index.html” is not found (2: No such file or directory), client:, server: xxxxx.com, request: “GET /index.php/apps/rainloop/app/?admin HTTP/1.1”, host: "xxxxx.com"
2018/02/21 05:53:57 [error] 2154#0: *139 “/home/user-data/www/default/index.php/apps/rainloop/app/index.html” is not found (2: No such file or directory), client:, server: box.xxxxxx.com, request: “GET /index.php/apps/rainloop/app/?admin HTTP/1.1”, host: "box.f2f10.com"
2018/02/21 05:54:52 [error] 2154#0: *188 “/home/user-data/www/xxxx.com/index.php/apps/rainloop/app/index.html” is not found (2: No such file or directory), client:, server: xxxxx.com, request: “GET /index.php/apps/rainloop/app/?admin HTTP/1.1”, host: “xxxxxx.com