Ownership and write rights on /home/user-data

Looking at my mail log (trying to answer another question here) I found this message:

box opendkim[28290]: example.nl: key data is not secure: /home/user-data is writeable and owned by uid 1001 which is not the executing uid (113) or the superuser

Either this is normal, or I changed the ownership on this directory when I tried to solve my backup problems last month.

Can someone confirm that root owns /home/user-data and that this directory should not be writeable in a standard MIAB configuration?



No, on my box user-data owns that folder and the folder is only writable by that user. I don’t know if that is the intended configuration but it makes sense to me…

Thanks for your reaction.

user-data now owns /home/user-data and I changed /home/user-data to drwx------ and that crippled MIAB. No more mail received, and complains about denied permissions when connecting with imap in the mail log. Changing /home/user-data to drwx–x--x solved that again.

I’ll see if I get the warning message about the insecure key data again in mail.log (the message that started this wild goose chase)

Still get the warning messages. However, some Googling turned up an old, closed issue (#125) regarding this OpenDkim behavior which is not considered a problem :slight_smile: