Ns for domain not active when moving domain to ns


#1

Hi,
I have a miab server that I also use to host a range of domains DNS records. It has worked perfectly for some time now. Today I wanted to move a new domain to the server and went to the tld admin (in this case a .dk domain so dk-hostmaster.dk). They have a nice self-service control panel where I can change the nameserver for my domain.
However, when I tried that today, it said: NS records missing for name server
I checked the custom DNS list in MIAB and it shows my domain just fine in the list with an A record for domain.tld and *.domain.tld
I tried restarting the nsd service but it did not change anything.
The nsd config seems to look ok having e.g.
:mydomain.dk. 1800 IN SOA ns1.myns-server.tech. hostmaster.myns-server.tech. 2019010702 7200 1800 1209600 1800

Any ideas to what I have done wrong/forgotten?


#2

If you just did the transfer today it can take up to 48 hours for NS records to properly propagate and be completely ready. If you do not want to give out personal information here, feel free to PM me and I can assist.