Not able to receive mail

I have just setup a new domain with MIAB. I used Custom DNS to set an A record for a website hosted elsewhere. The website is loading fine.

I have 1 e-mail address setup on the domain. I used Thunderbird to send an e-mail from this account and it worked fine.

When replying to that e-mail in Thunderbird I get the following message:

An error occurred while sending mail. The mail server responded:
Requested action not taken: mailbox unavailable or not local.
Please check the message recipient “” and try again.

I have “checked the status page, re-ran setup, and rebooted the box”

Any ideas?


How long has the server been online? DNS Records (especially for NEW MIAB setups) can take up to 48 hours to take affect.

I see you are using DigitalOcean (Can see from the IP set for make sure you are authorized with DO to even have port 25 access. You will need to contact their support for that.

I can see SMTP test on mxtoolbox at least pass, which is good, so you might not need to do the above, in which case I would make sure that you mailbox you are sending to actually exists.

It appears that email is now being delivered. If you are still having issues @drdandc comment back.

If you do the same test email and get the same result, I suggest using a different email account to test with.

The MIAB has been in operation for some time. Other e-mail accounts are still working.

I am getting different results depending on which account I am sending from as well as which account I am sending to. I will try to describe.

I have two sending account Send1 and Send2, both are accounts not using my MIAB server.
I have two receiving accounts RecvOld and RecNew, both are on my MIAB server.
RecvOld has been in operation for months. RecvNew is the new account that caused me to start this thread.

Send1 to RecvOld => no error on send, nothing received at RecvOld, nothing in Junk folder.

Send2 to RecvOld => no error on send, e-mail comes through instantly

Send1 to RecvNew => generates error on send as indicated in original post

Send2 to RecvNew => no error on send, e-mail comes through instantly

Send1 to Send2 => e-mail is delivered without errors.

So it seems Send1 can’t communicate with MIAB and it has different issues with different domains.


How did it appear that email was now being delivered. I didn’t receive an e-mail from you, so how did you test it?

If you want to pop into the Slack channel, I will be around most of the rest of the day.

Is email account ‘send1’ on the same mail server that formerly served this domain?

The error message suggests that the user account (RecvNew) was formerly handled by the same server that the mail was sent from and that there is a misconfiguration on that server. Was the email formerly being handled by cPanel shared hosting?

Thanks for getting back to me. You are absolutely correct. It was formerly being handled by cPanel shared hosting. I will look into that server configuration. That is impressive you could sort that out so quickly.

Thanks for for the e-mail verification link. That will come in handy.


Thank you. The key was …

The error message tells us that the mail exchanger was looking at localhost rather than a remote server.

Are you familiar with where the control for this is located in cPanel?

Where in the CPanel - I thought it would be the DNS settings but I have removed the old MX record and A records but it hasn’t helped. Be grateful if you could point me in the right direction.

Look for ‘Email Routing’ … set it to ‘Remote Mail Exchanger’. Make sure that you are manipulating the routing for the proper domain(s).

I was wrong. The server used Plesk no cPanel. I submitted a ticket to the provider and they have disabled the local post office. Everything is working now.

Thanks so much for your help alento!