NextCloud upgrade weirdness

I’ve done a fresh install of MIAB, which went reasonably smoothly. NextCloud went through its string up upgrades up to 25.x, which all seemed to work (apart from this issue which I worked around ok).

What’s odd is that if I run mailinabox again (because my postgrey installation seemed to be entirely missing), it went through the entire sequence of NC updates again. I’m a bit surprised that applying an “upgrade” from 25.x to 21.x would work at all, and I’m curious about why it’s even tried. Does the NC upgrade sequence not check whether NC is already upgraded?

Regarding the missing postgrey, the symptoms I saw included (from various places):

mv: cannot stat '/var/lib/postgrey/*': No such file or directory
ls: cannot access '/home/user-data/mail/postgrey': No such file or directory
FATAL: ERROR: can't open lock file: /home/user-data/mail/postgrey/db/postgrey.lock#012
Aug  2 22:25:42 mail postgrey[74655]: Couldn't unlink "/var/run/" [Permission denied]
Recipient address rejected: Server configuration problem;

From the outside, senders were being rejected with this error:

Recipient address rejected: Server configuration problem (in reply to RCPT TO command))

Re-running mailinabox seemed to resolve this, but I don’t know why/how it got into his state to start with.

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.