Newest update broke mail in a box

hello I’ve just updated mail in a box and it completely broke it I tried reinstalling it and it worked fine I updated it to the latest version and it was working fine but after a little bit it broke so now when I go to check status it always gives something went wrong.
I’m running mali in a box on Ubuntu 18.04 LTS X64

never mind it seems to have fixed itself

okay it keeps on doing it when I close my web browser and go back to it can anyone help

Could you be a bit more specific? Broke in what way, how have you tested?

If it is an urgent problem you might try on the Slack channel (linked from the mailinabox homepage)

it just keeps doing this

I can see it at least requires a reboot. Have you rebooted it?

It did not fix it keeps doing the same thing

Have you updated all the packages in Ubuntu?

it’s a fresh install why would I need to update

A “fresh” install of Ubuntu likely has a lot of updates. In fact, the biggest number of packages updated at one single time is usually immediately after a “fresh” install.

no need for “updates”

Try running apt-get update && apt-get upgrade and see if it updates anything.

also it actually seemed to be fixed when my domain glue record finally got updated

theres noting that needs updates

I see, so you ran the commands Ubuntu informed nothing required updating (though likely some updates are held back, which is also normal).

Try running the mailinabox command.

It will not delete anything unless you have custom edited MiaB files. Just answer the questions the same as before.

ok its done but its saying This domain’s DNSSEC DS record is not set

Does the MiaB dashboard load up when you log in now?

well i said this before