Mobile device sync

Has anyone please encountered an error, where mobile devices aosi/android sync only a few recent emails and some old emails from years ago? For example I have 25 emails from june 2021 and then 5emails from 2015, 10 from 2012 etc. Webmail and any PC client shows all emails correctly.

I have updated MIB to newest version, also the OS is newest version, but the problem persist.
This happens with emails, that were originally migrated with imapsysnc from exchange 2010 server.

I’d be grateful for any advice.

Can’t say I’ve had this problem. Might it be an issue with Z-push?

z-push admin

Has some troubleshooting options.

Thanks. Ive checked z-push-admin, but from what I can see all the users are synchronized, I see no errors. Still cant figure out why the emails dont sync. Ive tried some more devices, but the result is always the same, only a few emails are synced. The new ones are OK

Sorry to hear that. I’m using only iOS mobile devices and have not had problems. My email was moved from a previous imap server (not Exchange) using imapsync.

Did you try resync’ing a user/device with z-push?

Resyncing did not solve the problem. Tried it this week with multiple users and devices