MiaB with Windows Hyper-V

Has anyone run MiaB in a virtual machine on Hyper-V on windows server 2019?

I had a MiaB running like this perfectly until 3 months ago. But we had changes in our ISP and after that nothing else worked, or worse in my last tests it works for a day and then stops.

I’ve checked the entire forum, I’ve joined the slack channel, I’ve done dozens of installations, I’ve changed all my ISP configuration, I’ve changed the ISP, and after a few days everything stops working.

Last weekend I decided to redo all the configuration, on Saturday I installed a new VM on Windows Server 2019 Hyper-V and configured the MIAB, did some tests, sent email, configured additional domains, and everything was perfect, on Sunday I managed to send email from my home, when I arrived at the company on Monday the server was no longer responding.

nor access to the admin portal (https://my.ip/admin) works.

When checking the firewall I see that the ports are open sudo ufw status
when I use ex openssl s_client -connect private.ip:995 it works perfectly, however openssl s_client -connect public.ip:995 connection refused error 111

I don’t know what else to do, I would really like to be able to use MiaB, the project is very good, when it worked here for more than 3 months it was perfect.
So the question is, could it be something in Hyper-V, it’s not very common to use it that way, but for me it would be of great importance to have this project running on that server


1 Like

It absolutely is very likely that it is something in Hyper-V. Problem is that is a level above where anyone here is likely going to be able to assist you.

Most likely culprit – IP and routing issues. Networking. Something I personally cannot help with but maybe you can find someone who is experienced with Hyper-V to troubleshoot the network.

1 Like

You state But we had changes in our ISP and after that nothing else worked

Could it be possible that your ISP is just blocking port 995? as in this example
openssl s_client -connect private.ip:995 it works perfectly, however openssl s_client -connect public.ip:995 connection refused error 111
It looks like it works over private network but not over publicly routed internet this could be because your ISP is just blocking the port.

If you’re using a residential network you could try contacting support and seeing if they would unblock the port although I doubt they would as they are very strict on that.
If it is not a residential you can try contacting your ISP and asking them to unblock sed mail ports.

1 Like

Thanks for the answer.
However I believe it is no longer the ISP, because they give me full access, and there are other ports that I use on the same ISP that work normally on other servers, and I have already tried two different ISPs

An ISP can “Give you full access” but they could still in theory block the ports.

I had supposed “full access” on my ISP’s static block but they still blocked the mail ports until I contacted support and they opened the ports for me.

Morning guys!
I performed a new installation on a physical machine yesterday and so far everything is working perfectly, but on Hyper-V it also worked for a day or two, so I’ll wait a little longer to make sure it really is Hyper-V

Good morning everyone, I’m here again.
How to comment the system works for one or two days and then it simply stops, on the 21st and 22nd everything worked perfectly, but today in the morning we noticed that nothing else worked, not even port 80 or 443 tests work, see in the image how it was on the day 21 and this is now the NMAP response.
So in this case we can assume that the problem is not Hyper-V, I ask, are there logs that can give more details of the failures?
Today at the end of the day we are going to do tests without RouterOS (Mikrotik) to see if it could be some rule or blocking that he could be doing.
The port 8291 is the RouterOS (mikrotik) and the port 2000 cisco is the ISP.

1 Like

the IP of the capture tells me that you are from Brazil (the name made me believe that you were Spanish and I almost put this in Spanish).

I see that right now the domain is working for you, so I suppose you have solved it.

What I am going to tell you, take it more as a personal preference than as a technical indication: Windows Server is good at certain things, but as a virtualization system it is too heavy and too… monstrous. If you want to have a mail-in-a-box and a windows server coexisting on the same machine, it is best to mount a real virtualization system on the computer (many people use VMWare Esxi, although I prefer proxmox). You will have less problems and what happens in one machine will not influence the one next to it. Proxmox is a free system (like Mail-in-a-box) and tremendously powerful. Consider it for future assemblies.

1 Like

Check fail2ban.
try to access from a different ip address
Write a cron script that sends mail from box to gmail.

Hi Guys,

I have been runing a lot of Linux VMs on a Hyper-V boxes without any issues, so I can tell: it is possible, but if one should do that, that’s the question.

My personal PC runs Windows (with Hyper-V), so I decided to use Hyper-V on a standalone box. It is easier to move machines between the same hypervisor. However, I never used the Hyper-V host for anything else than virtualization.

I am not sure, if you use Windows Server 2019 host for anything else, but MS and experts advise dedicating a hardware machine for virtualization. So, if you need any Windows services - run them in VMs alongside Linux VMs (MIAB) and not on the host itself.

Always use “External Switch” to connect VMs directly to the switched network and configure VLANs at VM level, if you have use VLANs.

It is also a good habit to have at least one physical domain controller if your Hyper-V hosts are domain joined. It is not a requirement, but a DC may be installed on a NUC-type machine and will work fine.

And one more thing. Keep in mind that Microsoft has decided to stop supporting Hyper-V Server edition of Windows Server. That was the only way to use Microsoft’s virtualization for free. The new solution: Azure Stack HCI is a commercial offering and there are no free version or at least I don’t know anything about one. Maybe it is now a good time to do a switch if you wan’t a free or cheap virtualization.

The mega corporations keep getting greedier and greedier. :frowning:

1 Like

This topic was automatically closed 40 days after the last reply. New replies are no longer allowed.