MIAB installation stops at "Installing Munin (system monitoring)..."


i´m just running “sudo mailinabox” from time to time to see if anything is broken.

Since last time the installation stops at “Installing Munin (system monitoring)…”. Is there any way to see why the installation can’t go on? No error message etc. is displayed.

Running sudo management/status_checks.py gives:

Traceback (most recent call last):
  File "management/status_checks.py", line 983, in <module>
    run_checks(False, env, ConsoleOutput(), pool)
  File "management/status_checks.py", line 49, in run_checks
    if not run_services_checks(env, output, pool):
  File "management/status_checks.py", line 97, in run_services_checks
    output.print_ok("All system services are running.")
  File "management/status_checks.py", line 913, in print_ok
    self.print_block(message, first_line="\u2713  ")
  File "management/status_checks.py", line 922, in print_block
    print(first_line, end='', file=self.buf)
UnicodeEncodeError: 'ascii' codec can't encode character '\u2713' in position 0: ordinal not in range(128)

Looks like you have an illegal character in your setup. What is your admin email?

My admin email doesn´t contain any illegal character. In a previous MIAB installation everything also worked fine with the same configuration. Do you have an idea?

You have something somewhere that is not able to be encoded, the “\u2713” is a “?”. IDK what else to tell you, there error message doesn’t lie.

It’s also possible that script is broken too - Maybe look into python version and such

Thanks for your help.

I don´t know where to search… According to internet this
code “\u2713” is a check mark: https://www.fileformat.info/info/unicode/char/2713/index.htm

The only place where this hook is used is the status page. Can that be a clue?

~~ mean I told ya it was a question mark lol.~~
EDIT: I didn’t see that but you said “Check Mark” which is actually the correct unicode char. My apologies for the remark.

As for the status page, you are sure there is no email, domain, alias, servername, etc,etc, is not using either a weird character (check language, is the server en-US?) or the actual question mark?

The checkmark is from the status checks output indicating a check was OK.

Displaying Unicode characters on terminals needs to be set up sometimes. Running this before running status checks should fix it:

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8
export LANGUAGE=en_US.UTF-8

We do this in some of our scripts. (EDIT: And by “our scripts” I mean the Mail-in-a-Box source code.)


Thats it!

But i´m still having problems running “sudo mailinabox”. Any ideas why this stops whithout any error at “Installing Munin (system monitoring)…”?

Nothing in syslog about that?

Okay now it worked! Maybe cause of the commands from @JoshData

1 Like

I tried to update MIAB to v0.27. I noticed that the installation stopped again at Munin. Josh’s command didn’t help either.

If I comment out “source setup/munin.sh” in “start.sh” the “start.sh” runs without problems. Any ideas?

Having this problem with 0.28 - have been updating many versions without problems (running this MIAB server for years).

Edit: Rebooting got it further, but then it errors during the LetsEncrypt setup. Manually registering the Letsencrypt account fixes the error. (certbot register --config-dir /home/user-data/ssl/lets_encrypt)


I faced the same issue. Following the same steps (reboot, certbot register) worked for me too.