MiaB Backup to S3 Storage


I would like to be able to backup my MiaB VPS (running Ubuntu 18.04.5 LTS) to a S3 storage (AWS, Wasabi, etc.). I understand that Duplicity is installed as part of MiaB packages.

I’m not well versed in Duplicity but is it possible to take advantage of Duplicity to create an “almost complete” backup of MiaB (not including Ubuntu software)?

I’d rather have the backup stored off-site than somewhere else in my server.



Just navigate to the ‘Backup Status’ page in the dashboard and enter your S3 credentials.

I thought it was hardcoded to Amazon S3 because the values kept clearing out. I had thought it wouldn’t go to Wasabi because it kept changing back to AmazonAWS.

I think it is working so I guess I have to wait next day to find out.

I’ve only used the local backup option, so if there is a problem with one of the others just come back and there are several people who can help you further.

AFAIK, the backups are only to AWS S3, not S3-like services. You will find out definitively tomorrow.

Once you saved, s3 fields will all blank out, but your backup will work (hardcoded to AWS only)

Yep, we use it to backup to UpCloud S3 object storage and it works perfectly.

The fact that the form fields blank out on save threw me a bit at first as well, but 12 hours later there it was and it has worked flawlessly since.

It would be really good if the backup page made this clearer actually, as it refers multiple times to Amazon and the implication is that you can only use AWS buckets.

1 Like

In fact, there isn’t a need to wait for the backup to kick in. You can initiate a manual back up in your server.

sudo ./mailinabox/management/backup.py

There won’t be any response but you should be able to see the encrypted files in S3 if it worked.

Didn’t even realize you had S3 built in, I have been mounting via s3fs and running rsync…

I checked Wasabi and I do confirm three files were placed there earlier this morning.

Thanks for the correction that it does work for other S3 formats! IIRC that was not the case originally. The change log shows that this was implemented in v 0.42b. This would explain the backup page not reflecting reality and why I was unaware.

Now, if only I could remember how to correctly do a pull request, I’d fix that. :frowning:

I’ve been meaning to make one since I read this thread yesterday, just trying to get the wording right in my head.

1 Like

PRs are now much easier than every before. GitHub will automatically create the fork and enter the editing page mode inside your fork, then when you are done it will ask if you want to submit a PR.

From the perspective of command line git, it’s amazingly accessible now.

I’ve created a PR, hopefully the wording makes everything clearer.