Messages aren't fully deleting with IMAP

I’m trying to delete messages from my MIAB using the npm IMAP package. I am not in readonly-mode, I am able to use addFlag to add the flag “Deleted” and I also run expunge when using closeBox(). However, I still see the relevant messages in the webmail inbox, greyed out and with the “no entry sign” (https://www.emojibase.com//resources/img/emojis/apple/x1f6ab.png.pagespeed.ic.A3AI1svvLt.png) icon, but still visible and not expunged. What am I missing?

Which client are you using?

Copy a sentence in the mail,

Login with ssh to your mailserver
in /home/user-data/mail/mailboxes//, you will find a couple of directories.

Go to the directory of your account and try something like the following command:

find . -type f -exec grep -l “my strange sentence” {} ;

It will list all the files containing “my strange sentence”

I am using the standard client box.myurl.com/mail. That’s where I see the emails remaining even after “deleted” by node-imap

In that mailclient, there is right to your email address 3 dots (small pull down menu); the first menu item. In English probably cleanup or purge, that will do the trick for that folder.

The other option is in settings, and then the server settings and the lowest mailbox options

(I’ve my client on dutch, so I didn’t get the right English descriptions)

ok, in user-interface, I can change the language settings, so it’s:
Settings => Server Settings => Maintenance (Clear Trash/Compact Inbox, both checked)
And for a mailfolder:
Mail=> (top bar email dots) → Compact

Hope this helps

Thank you sander-schippers, that fixed it! I checked both boxes and now they disappear automatically. Hadn’t thought to check my MIAB Settings.