Let's Encrypt problem

I’m running MIAB on Amazon micro instance.
Launched it in Aug 2015 (v0.14 I think), today upgraded to v0.16.

I have 3 subdomains - mail, www and domain itself.
mail and domain have OpenSSL certs, but www is self-signed.

I tried to provision Let’s Encrypt certificate to www today from admin console.
However, when I try to click on “Accept and Provision” green button, I get “Something went wrong” message and admin console stops responding with “502 Bad Gateway / nginx” page.
Roundcube and receiving\sending email works fine.
After reboot Admin console works fine as well - until I try to provision again.

Any suggestions what’s going on? Which logs to check?
How to restart admin console without server reboot?

Check /var/log/syslog.

How to restart admin console without server reboot?

sudo service mailinabox restart

In my case this was caused by mailinabox running on an lxc container with NAT, and I haven’t got NAT loopback/hairpinning working yet, so mailinabox cannot reach itself via the public ip. (the status check page also mentions this)

I added the FQDN, the domain and the www to the localhosts file as , removed /home/user-data/ssl/lets_encrypt and ran

~/mailinabox/management# ./ssl_certificates.py -v

Now it worked.